summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-05-07 14:08:34 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-05-07 14:09:58 +0300
commitbf51acfab67751f7d5c9e3963f494bd040bf5760 (patch)
treeb185b7855e25211b3ca4948c523ebb9eaf85ed05 /app-misc
parentdev-python/random2: Port to python3.10 (diff)
downloadgentoo-bf51acfab67751f7d5c9e3963f494bd040bf5760.tar.gz
gentoo-bf51acfab67751f7d5c9e3963f494bd040bf5760.tar.bz2
gentoo-bf51acfab67751f7d5c9e3963f494bd040bf5760.zip
app-misc/tmux: fix shift-f5 keybinding
Closes: https://bugs.gentoo.org/788307 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/tmux/files/tmux-fix-bindings.patch45
-rw-r--r--app-misc/tmux/tmux-3.2-r1.ebuild (renamed from app-misc/tmux/tmux-3.2.ebuild)1
2 files changed, 46 insertions, 0 deletions
diff --git a/app-misc/tmux/files/tmux-fix-bindings.patch b/app-misc/tmux/files/tmux-fix-bindings.patch
new file mode 100644
index 000000000000..6436302f0557
--- /dev/null
+++ b/app-misc/tmux/files/tmux-fix-bindings.patch
@@ -0,0 +1,45 @@
+From f2951bd4a560692048e68bf29a5b0a288346a7d4 Mon Sep 17 00:00:00 2001
+From: Nicholas Marriott <nicholas.marriott@gmail.com>
+Date: Wed, 5 May 2021 07:23:23 +0100
+Subject: [PATCH] Remove old shift function keys which interfere with xterm
+ keys now. GitHub issue 2696.
+
+---
+ input-keys.c | 24 ------------------------
+ 1 file changed, 24 deletions(-)
+
+diff --git a/input-keys.c b/input-keys.c
+index ffd2201c0..be83600e5 100644
+--- a/input-keys.c
++++ b/input-keys.c
+@@ -94,30 +94,6 @@ static struct input_key_entry input_key_defaults[] = {
+ { .key = KEYC_F12,
+ .data = "\033[24~"
+ },
+- { .key = KEYC_F1|KEYC_SHIFT,
+- .data = "\033[25~"
+- },
+- { .key = KEYC_F2|KEYC_SHIFT,
+- .data = "\033[26~"
+- },
+- { .key = KEYC_F3|KEYC_SHIFT,
+- .data = "\033[28~"
+- },
+- { .key = KEYC_F4|KEYC_SHIFT,
+- .data = "\033[29~"
+- },
+- { .key = KEYC_F5|KEYC_SHIFT,
+- .data = "\033[31~"
+- },
+- { .key = KEYC_F6|KEYC_SHIFT,
+- .data = "\033[32~"
+- },
+- { .key = KEYC_F7|KEYC_SHIFT,
+- .data = "\033[33~"
+- },
+- { .key = KEYC_F8|KEYC_SHIFT,
+- .data = "\033[34~"
+- },
+ { .key = KEYC_IC,
+ .data = "\033[2~"
+ },
diff --git a/app-misc/tmux/tmux-3.2.ebuild b/app-misc/tmux/tmux-3.2-r1.ebuild
index bbd5c65d4559..11298a03e488 100644
--- a/app-misc/tmux/tmux-3.2.ebuild
+++ b/app-misc/tmux/tmux-3.2-r1.ebuild
@@ -42,6 +42,7 @@ DOCS=( CHANGES README )
PATCHES=(
"${FILESDIR}/${PN}-2.4-flags.patch"
+ "${FILESDIR}/${PN}-fix-bindings.patch"
# upstream fixes (can be removed with next version bump)
)