summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2016-09-10 09:46:45 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-09-12 13:59:33 +0200
commitc2322d5d9ee237391e32fbd0f7e00af6a5a633f6 (patch)
tree89cfdb7dc1773cb3f74f4906bbdc7bafdaf06cc1 /app-misc
parentapp-misc/carbon-c-relay: version bump to v2.2 (diff)
downloadgentoo-c2322d5d9ee237391e32fbd0f7e00af6a5a633f6.tar.gz
gentoo-c2322d5d9ee237391e32fbd0f7e00af6a5a633f6.tar.bz2
gentoo-c2322d5d9ee237391e32fbd0f7e00af6a5a633f6.zip
app-misc/ddctool: version bump to 0.5.0.
- Updated dependencies based on new information from upstream. - Added new configure options added in this release - Renamed the use flags to better reflect what they do (in part due to the above mentioned config changes). - Remove old version as upstream doesn't want it used in a production environment. This is considered the first formal release by upstream. Previous versions were more like an alpha version. Release notes: http://www.ddctool.com/release_notes/#05 Signed off by Jonathan Scruggs (j.scruggs@gmail.com, irc: Dracwyrm) Closes: https://github.com/gentoo/gentoo/pull/2287 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ddctool/Manifest2
-rw-r--r--app-misc/ddctool/ddctool-0.5.0.ebuild (renamed from app-misc/ddctool/ddctool-0.4.2.ebuild)65
-rw-r--r--app-misc/ddctool/metadata.xml16
3 files changed, 52 insertions, 31 deletions
diff --git a/app-misc/ddctool/Manifest b/app-misc/ddctool/Manifest
index d413b270ec4c..14a87e066372 100644
--- a/app-misc/ddctool/Manifest
+++ b/app-misc/ddctool/Manifest
@@ -1 +1 @@
-DIST ddctool-0.4.2.tar.gz 739613 SHA256 742465d74247c21a87247e3a386d0cbcf95808cde9fc88efae21f21c12ae9748 SHA512 7b86ae475f877ff4e66a51e0612fe505479e88b6221c74e7951e10537a3d9720f0f7c82cbbaaa990aa6daef7e1aabf493f6eb59e908af61a8f1159b9d9ac16a8 WHIRLPOOL 4d32cf667c9a61790c5ac1a02338349b085d8922b3b89e28814b394bb975c74452dd7dd8d2f14561256d724ac10f032debab8b686700783beba4dbc00b3b4238
+DIST ddctool-0.5.0.tar.gz 322864 SHA256 8773b98f7ca226f8b9cdca3c681ddf0f8aacb5d2c1591764e2a9080a14fe518d SHA512 5fc55a4363335eb8468a73f6e617cba7efcb454f8cefa081c6d13d9c2ac35cc191001a466c61ecfc9c944aea5b837b993646b4b2c78dfb63057ef01c3c05fed5 WHIRLPOOL 66679e7f2a81dab012e38aad24961b5aa3f3860f64b49e0818362c3ac5f5bab2a1a4e0528cf27540041e4f8a548342a1d7f4bd1b422c4185a83721dc6720b218
diff --git a/app-misc/ddctool/ddctool-0.4.2.ebuild b/app-misc/ddctool/ddctool-0.5.0.ebuild
index e64c5797e169..71d1c3975c64 100644
--- a/app-misc/ddctool/ddctool-0.4.2.ebuild
+++ b/app-misc/ddctool/ddctool-0.5.0.ebuild
@@ -4,28 +4,31 @@
EAPI=6
-inherit linux-info udev user
+inherit autotools linux-info udev user
DESCRIPTION="Program for querying and changing monitor settings"
HOMEPAGE="http://www.ddctool.com/"
-MY_GIT_COMMIT="9712e9b54693872cd390476a7606fc8d13b66034"
-SRC_URI="https://github.com/rockowitz/ddctool/raw/${MY_GIT_COMMIT}/${P}.tar.gz"
+SRC_URI="https://github.com/rockowitz/ddctool/archive/v${PV}.tar.gz -> ${P}.tar.gz"
# Binary drivers need special instructions compared to the open source counterparts.
# If a user switches drivers, they will need to set different use flags for
# Xorg or Wayland or Mesa, so this will trigger the rebuild against
# the different drivers.
-IUSE="udev-i2c udev-usb video_cards_fglrx video_cards_nvidia"
+IUSE="usb-monitor user-permissions video_cards_fglrx video_cards_nvidia"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="x11-libs/libXrandr"
+RDEPEND="x11-libs/libXrandr
+ sys-apps/i2c-tools
+ virtual/udev
+ usb-monitor? (
+ dev-libs/hidapi
+ virtual/libusb:1
+ sys-apps/usbutils )"
DEPEND="video_cards_fglrx? ( x11-libs/amd-adl-sdk )
- udev-usb? ( virtual/libusb )
- virtual/udev
virtual/pkgconfig
${RDEPEND}"
@@ -33,41 +36,59 @@ pkg_pretend() {
# This program needs /dev/ic2-* devices to communicate with the monitor.
CONFIG_CHECK="~I2C_CHARDEV"
ERROR_I2C_CHARDEV="You must enable I2C_CHARDEV in your kernel to continue"
- if use udev-usb; then
- CONFIG_CHECK="~USB_HIDDEV"
+ if use usb-monitor; then
+ CONFIG_CHECK+="~HIDRAW ~USB_HIDDEV"
+ ERROR_HIDRAW="HIDRAW is needed to support USB monitors"
ERROR_I2C_CHARDEV="USB_HIDDEV is needed to support USB monitors"
fi
+
+ # Now do the actual checks setup above
+ check_extra_config
+}
+
+src_prepare() {
+ eautoreconf
+ default
}
src_configure() {
- econf $(usex video_cards_fglrx "--with-adl-headers=/usr/include/ADL" "")
+ local myeconfargs=(
+ $(usex video_cards_fglrx "--with-adl-headers=/usr/include/ADL" "")
+ $(use_enable usb-monitor usb)
+ )
+
+ econf ${myeconfargs[@]}
}
src_install() {
default
- use udev-i2c && udev_dorules data/etc/udev/rules.d/45-ddctool-i2c.rules
- use udev-usb && udev_dorules data/etc/udev/rules.d/45-ddctool-usb.rules
+ if use user-permissions; then
+ udev_dorules data/etc/udev/rules.d/45-ddctool-i2c.rules
+ if use usb-monitor; then
+ udev_dorules data/etc/udev/rules.d/45-ddctool-usb.rules
+ fi
+ fi
}
pkg_postinst() {
- if use udev-i2c; then
+ if use user-permissions; then
enewgroup i2c
- udev_reload
einfo "To allow non-root users access to the /dev/i2c-* devices, add those"
einfo "users to the i2c group: usermod -aG i2c user"
einfo "Restart the computer or reload the i2c-dev module to activate"
einfo "the new udev rule."
einfo "For more information read: http://www.ddctool.com/i2c_permissions/"
- fi
- if use udev-usb; then
- enewgroup video
+ if use usb-monitor; then
+ enewgroup video
+ einfo "To allow non-root users access to USB monitors, add those users"
+ einfo "to the video group: usermod -aG video user"
+ einfo "Restart the computer, reload the hiddev and hidraw modules, or replug"
+ einfo "the monitor to activate the new udev rule."
+ einfo "For more information read: http://www.ddctool.com/usb/"
+ fi
+
udev_reload
- einfo "To allow non-root users access to the USB monitor, add those users"
- einfo "to the video group: usermod -aG video user"
- einfo "Restart the computer, reload the hiddev module, or replug the monitor"
- einfo "to activate the new udev rule."
- einfo "For more information read: http://www.ddctool.com/usb/"
fi
if use video_cards_nvidia; then
diff --git a/app-misc/ddctool/metadata.xml b/app-misc/ddctool/metadata.xml
index 7b3b1c04807e..a7fa6864a82f 100644
--- a/app-misc/ddctool/metadata.xml
+++ b/app-misc/ddctool/metadata.xml
@@ -17,16 +17,16 @@
support for monitors (such as Apple displays) that implement MCCS using
a USB connection.
</longdescription>
+
<use>
- <flag name="udev-i2c">
- Adds a udev rule to allow non-root users in the i2c group to
- access the /dev/i2c-* devices. Otherwise, only root will be
- able to use ddctool.
+ <flag name="user-permissions">
+ Adds a udev rules to allow non-root users in the i2c group to
+ access the /dev/i2c-* devices. If usb-monitor is selected, users
+ will need to be added to the video group to access the USB monitor.
+ Otherwise, only root will be able to use ddctool.
</flag>
- <flag name="udev-usb">
- Adds a udev rule to allow non-root users in the video group to
- access USB connected monitors. Otherwise, only root will be
- able to use ddctool.
+ <flag name="usb-monitor">
+ Adds support for monitors attached via USB.
</flag>
</use>
</pkgmetadata>