summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-07-16 12:05:38 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-07-17 14:33:36 +0200
commitc98a7c6a8d1dc238837a94a2e723592f1d2e127f (patch)
tree66a806f9267c73ce46a54f81a17bb21c6ba2184e /app-misc
parentapp-misc/openrgb-plugin-effects: add 0.9 (diff)
downloadgentoo-c98a7c6a8d1dc238837a94a2e723592f1d2e127f.tar.gz
gentoo-c98a7c6a8d1dc238837a94a2e723592f1d2e127f.tar.bz2
gentoo-c98a7c6a8d1dc238837a94a2e723592f1d2e127f.zip
app-misc/openrgb-plugin-skin: add 0.9
Bug: https://bugs.gentoo.org/910405 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/openrgb-plugin-skin/Manifest1
-rw-r--r--app-misc/openrgb-plugin-skin/openrgb-plugin-skin-0.9.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-misc/openrgb-plugin-skin/Manifest b/app-misc/openrgb-plugin-skin/Manifest
index eb03452e78df..5aa5302a16fd 100644
--- a/app-misc/openrgb-plugin-skin/Manifest
+++ b/app-misc/openrgb-plugin-skin/Manifest
@@ -1 +1,2 @@
DIST OpenRGBSkinPlugin-release_0.8.tar.bz2 22711 BLAKE2B 25325c6be5cf619940e79e4f431871478e3026188d7aba4b8220a99afda8f75d18ffeafa0f905110d4ce44f5d7e28208f3d7b358cfadfcd4719a22f1ef5cf70d SHA512 89b9a4bcda4600ea7dbd05972bba7c5f8d917606b3def4971e6ccff84d8510ca420747dd85d3395bfea29e62adc775b592f9cbe20a6966776a46e15593f2cf59
+DIST OpenRGBSkinPlugin-release_0.9.tar.bz2 22781 BLAKE2B 46a342927f589c1b9bdbdfc094d8f85007897c5cfac9265d6a8efbafdd5bdb8f3f92927b052e4a52310cf5e2a7404590c16964c0c041ab6035dff24ee41b8e33 SHA512 51a6b11ca95679d9abbb600e77c50eac59138b2f9e080e5eba1606405f95446da0582327e2d071740e1cb1845604e895286cc06512b0769ae1d57937e2df818c
diff --git a/app-misc/openrgb-plugin-skin/openrgb-plugin-skin-0.9.ebuild b/app-misc/openrgb-plugin-skin/openrgb-plugin-skin-0.9.ebuild
new file mode 100644
index 000000000000..67cebc546436
--- /dev/null
+++ b/app-misc/openrgb-plugin-skin/openrgb-plugin-skin-0.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+SRC_URI="https://gitlab.com/OpenRGBDevelopers/OpenRGBSkinPlugin/-/archive/release_${PV}/OpenRGBSkinPlugin-release_${PV}.tar.bz2"
+S="${WORKDIR}/OpenRGBSkinPlugin-release_${PV}"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Plugin for OpenRGB that allows you to customize the look and feel of OpenRGB"
+HOMEPAGE="https://gitlab.com/OpenRGBDevelopers/OpenRGBSkinPlugin"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=app-misc/openrgb-0.9:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+"
+
+src_prepare() {
+ default
+ rm -r OpenRGB || die
+ ln -s "${ESYSROOT}/usr/include/OpenRGB" . || die
+ sed -e '/^GIT_/d' -i *.pro || die
+
+ # Because of -Wl,--export-dynamic in app-misc/openrgb, this resources.qrc
+ # conflicts with the openrgb's one. So rename it.
+ sed -e 's/resources.qrc/resources_skin_plugin.qrc/' -i *.pro || die
+ mv --no-clobber resources.qrc resources_skin_plugin.qrc || die
+}
+
+src_configure() {
+ eqmake5 \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/OpenRGB/plugins
+ doexe libOpenRGBSkinPlugin.so.1.0.0
+}