summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 07:05:59 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:09:41 +0100
commitcb90b9f26c9b9d7eead93b4bde03dc9711e7db0a (patch)
tree5482ec1225b086eca3a334bdda581905a7e7d49d /app-misc
parentapp-laptop/ibam: respect ${PKG_CONFIG}, use PATCHES=() (diff)
downloadgentoo-cb90b9f26c9b9d7eead93b4bde03dc9711e7db0a.tar.gz
gentoo-cb90b9f26c9b9d7eead93b4bde03dc9711e7db0a.tar.bz2
gentoo-cb90b9f26c9b9d7eead93b4bde03dc9711e7db0a.zip
app-misc/ytree: respect ${PKG_CONFIG}, don't use pkg_setup for tc-export
* Respect ${PKG_CONFIG} in our patch and export it. * pkg_setup is an odd choice for an action which only affects compilation (so not binary packages). Let's use src_configure instead. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ytree/files/ytree-1.99-tinfo.patch2
-rw-r--r--app-misc/ytree/ytree-2.02.ebuild8
-rw-r--r--app-misc/ytree/ytree-2.03.ebuild6
3 files changed, 10 insertions, 6 deletions
diff --git a/app-misc/ytree/files/ytree-1.99-tinfo.patch b/app-misc/ytree/files/ytree-1.99-tinfo.patch
index 9656cce88d51..47b5f2924a56 100644
--- a/app-misc/ytree/files/ytree-1.99-tinfo.patch
+++ b/app-misc/ytree/files/ytree-1.99-tinfo.patch
@@ -9,7 +9,7 @@ Bug: https://bugs.gentoo.org/690348
READLINE = -DREADLINE_SUPPORT
CFLAGS += -D_GNU_SOURCE $(COLOR) $(CLOCK) $(READLINE) $(ADD_CFLAGS)
-LDFLAGS += -lncurses -lreadline
-+LDFLAGS += `pkg-config --libs ncurses` -lreadline
++LDFLAGS += `${PKG_CONFIG} --libs ncurses` -lreadline
###########################
# LINUX with Wide character support (testet with ncurses 5.4)
diff --git a/app-misc/ytree/ytree-2.02.ebuild b/app-misc/ytree/ytree-2.02.ebuild
index a3a24fd384af..b44c98a5a576 100644
--- a/app-misc/ytree/ytree-2.02.ebuild
+++ b/app-misc/ytree/ytree-2.02.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,8 +26,10 @@ PATCHES=(
DOCS=( CHANGES README THANKS ytree.conf )
-pkg_setup() {
- tc-export CC
+src_configure() {
+ tc-export CC PKG_CONFIG
+
+ default
}
src_install() {
diff --git a/app-misc/ytree/ytree-2.03.ebuild b/app-misc/ytree/ytree-2.03.ebuild
index 719e4443d480..e0c2c496a3a4 100644
--- a/app-misc/ytree/ytree-2.03.ebuild
+++ b/app-misc/ytree/ytree-2.03.ebuild
@@ -22,8 +22,10 @@ RDEPEND="${DEPEND}"
DOCS=( CHANGES README THANKS ytree.conf )
-pkg_setup() {
- tc-export CC
+src_configure() {
+ tc-export CC PKG_CONFIG
+
+ default
}
src_install() {