summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-09-18 11:17:22 -0400
committerTim Harder <radhermit@gentoo.org>2016-09-18 11:47:05 -0400
commitdddb971d581bd20944368a4069e2f3d199dff4e2 (patch)
tree1c606532a521eabbacb2f3aaef4c1819830e8b8b /app-misc
parentsys-apps/iproute2: refreshed live ebuild (diff)
downloadgentoo-dddb971d581bd20944368a4069e2f3d199dff4e2.tar.gz
gentoo-dddb971d581bd20944368a4069e2f3d199dff4e2.tar.bz2
gentoo-dddb971d581bd20944368a4069e2f3d199dff4e2.zip
app-misc/evemu: version bump to 2.5.0
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/evemu/Manifest1
-rw-r--r--app-misc/evemu/evemu-2.5.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/evemu/Manifest b/app-misc/evemu/Manifest
index 6110031de0bb..453f0a9be7ef 100644
--- a/app-misc/evemu/Manifest
+++ b/app-misc/evemu/Manifest
@@ -1,3 +1,4 @@
DIST evemu-2.1.0.tar.xz 502240 SHA256 0c87360882751356e9f977ebf7438c00fe97deb232ac725dd86e5ba78203ee97 SHA512 16ed613aa465d85f617a5dd6b958b0480c55477836effc86c293facdb500152d5b387a79f14802f2db6a3c721cc754cac2e8fc605f5e689962742b8fc361c81b WHIRLPOOL bc4e9631eebe6329d726adf853e8ef716246d70cf4f3ee50497bec6d654c8483c9291a40f532d488813d0c2568cd106e03a131cfa6aab86f037ad3ee1f0a8d18
DIST evemu-2.2.0.tar.xz 492184 SHA256 e0f79808959d1b1f307a3d5add8ee9e5786d926e9aeb0045dadb85c7350d0a3c SHA512 638fa4962dae2aa88d70d1c30a244eab67ccc102af47a6de4b93f32b9f2b9d767d7f358efb71964c62f461e93c431bb679ad7019e2509f0cd4c02bd0e94a29d9 WHIRLPOOL 0f7cd045a8ad217a562fe640c5fc0f0bff890a725e1786741a5a412f24a866c997f18bf0dd404a804ed2e0718b85464797d21e1f8a3fdbee63216504d12ac09e
DIST evemu-2.4.0.tar.xz 505848 SHA256 0706ea5a830203f9cdb30c0e10c8c41d2427128ba9041543a5ae157fa3b4a30e SHA512 e629a0eedb6ce58d3f088b279f45b87117b30b01af07e53dd5515ced7ea15293476fafe9aa9832e6758a6953ad7a462b0fae0a0996181eec327377176cf00c7a WHIRLPOOL ad909f5e074dfdd0d6c9f3660844024f94da587f97cf9181e5ab1232fe077c8df47cca045b598a472bbf6ec776c2cbf313908a800d95a539173770080fb388ce
+DIST evemu-2.5.0.tar.xz 506092 SHA256 541cc138f0215b7d0cd4ad5e6bb1402518ffc5e31294c36bb67b4ff1791bb27f SHA512 7de37aeaa122501783f4b658bd18353a6f413ff57ce1feec71e0eedd21eba3e479ff6ffb79dbb7658a337c824f4575915f13edcfdf8d2ce52a1fdbd41e1610be WHIRLPOOL 094294327d3226918ded20bd5e36d05abe78b3aa46f45bd777ae0442033911cfafd572fb4f92b7509037b4e264e016c0287234d6b16e17e81e9ea1a38c4298c8
diff --git a/app-misc/evemu/evemu-2.5.0.ebuild b/app-misc/evemu/evemu-2.5.0.ebuild
new file mode 100644
index 000000000000..18259c7e5c96
--- /dev/null
+++ b/app-misc/evemu/evemu-2.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="tools and bindings for kernel evdev device emulation, data capture, and replay"
+HOMEPAGE="https://www.freedesktop.org/wiki/Evemu/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ >=dev-libs/libevdev-1.2.99.902"
+DEPEND="app-arch/xz-utils
+ ${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable python python-bindings)
+}
+
+src_test() {
+ if use python ; then
+ if [[ ! ${EUID} -eq 0 ]] || has sandbox $FEATURES || has usersandbox $FEATURES ; then
+ ewarn "Tests require userpriv, sandbox, and usersandbox to be disabled in FEATURES."
+ else
+ emake check
+ fi
+ fi
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}