summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-01 20:05:31 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-01 20:05:31 +0200
commitff505acf8b6e0cdf3edcee56d58079f4e4b17a31 (patch)
treead0dd0b6a5d1f9219e8a228489e0ddc63529bc14 /app-misc
parentdev-java/osgi-compendium: eapi7 + java 1.8 + newer servlet api (diff)
downloadgentoo-ff505acf8b6e0cdf3edcee56d58079f4e4b17a31.tar.gz
gentoo-ff505acf8b6e0cdf3edcee56d58079f4e4b17a31.tar.bz2
gentoo-ff505acf8b6e0cdf3edcee56d58079f4e4b17a31.zip
app-misc/figlet: fix building on musl
* The patch is from Alpine and the ebuild changes are not copyrightable. Closes: https://github.com/gentoo/gentoo/pull/20385 Closes: https://bugs.gentoo.org/608172 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/figlet/figlet-2.2.5-r1.ebuild2
-rw-r--r--app-misc/figlet/files/figlet-2.2.5-musl.patch36
2 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/figlet/figlet-2.2.5-r1.ebuild b/app-misc/figlet/figlet-2.2.5-r1.ebuild
index 7514e810fb65..2d98e79b36b3 100644
--- a/app-misc/figlet/figlet-2.2.5-r1.ebuild
+++ b/app-misc/figlet/figlet-2.2.5-r1.ebuild
@@ -13,6 +13,8 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+PATCHES=( "${FILESDIR}"/${P}-musl.patch )
+
src_compile() {
emake clean
emake \
diff --git a/app-misc/figlet/files/figlet-2.2.5-musl.patch b/app-misc/figlet/files/figlet-2.2.5-musl.patch
new file mode 100644
index 000000000000..6294d9d889dd
--- /dev/null
+++ b/app-misc/figlet/files/figlet-2.2.5-musl.patch
@@ -0,0 +1,36 @@
+From 88428a728e1f99dcdc63d7c5ff0cd8b6cda37576 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue, 3 Jun 2014 10:59:40 +0000
+Subject: [PATCH] Fix build with musl libc
+
+Avoid using the glibc internal macros __BEGIN/__END_DECLS.
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ utf8.h | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/utf8.h b/utf8.h
+index 0631b8a..a3e09bd 100644
+--- a/utf8.h
++++ b/utf8.h
+@@ -27,13 +27,17 @@
+ #define UTF8_IGNORE_ERROR 0x01
+ #define UTF8_SKIP_BOM 0x02
+
+-__BEGIN_DECLS
++#ifdef __cplusplus
++extern "C" {
++#endif
+
+ size_t utf8_to_wchar(const char *in, size_t insize, wchar_t *out,
+ size_t outsize, int flags);
+ size_t wchar_to_utf8(const wchar_t *in, size_t insize, char *out,
+ size_t outsize, int flags);
+
+-__END_DECLS
++#ifdef __cplusplus
++}
++#endif
+
+ #endif /* !_UTF8_H_ */