summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-04 08:31:36 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-04 08:32:47 +0200
commitd101b6c9d70882f7605fb608d44bf22112830f08 (patch)
tree1b2f66efc7da38635598e375bc5daee46cda9cc7 /app-mobilephone/dfu-util/dfu-util-0.11.ebuild
parentdev-embedded/u-boot-tools: Remove old 2021.04_rc2 (diff)
downloadgentoo-d101b6c9d70882f7605fb608d44bf22112830f08.tar.gz
gentoo-d101b6c9d70882f7605fb608d44bf22112830f08.tar.bz2
gentoo-d101b6c9d70882f7605fb608d44bf22112830f08.zip
app-mobilephone/dfu-util: Version bump to 0.11
Closes: https://bugs.gentoo.org/756385 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'app-mobilephone/dfu-util/dfu-util-0.11.ebuild')
-rw-r--r--app-mobilephone/dfu-util/dfu-util-0.11.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-mobilephone/dfu-util/dfu-util-0.11.ebuild b/app-mobilephone/dfu-util/dfu-util-0.11.ebuild
new file mode 100644
index 000000000000..0f4c6cd5a619
--- /dev/null
+++ b/app-mobilephone/dfu-util/dfu-util-0.11.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="git://git.code.sf.net/p/dfu-util/dfu-util"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="implements the Host (PC) side of the USB DFU (Device Firmware Upgrade) protocol"
+HOMEPAGE="http://dfu-util.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}