summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorktrace <ktrace@yandex.ru>2019-03-04 13:13:19 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-04 12:52:34 +0100
commit70ae7dd34071cb9cc2017a249a409394a03f6193 (patch)
tree6fe0052bc432f6144486fe3fb4c5f77265cc2fba /app-mobilephone/gammu/gammu-1.39.0-r1.ebuild
parentgnome-base/gnome-control-center: bump to 3.28.2 (diff)
downloadgentoo-70ae7dd34071cb9cc2017a249a409394a03f6193.tar.gz
gentoo-70ae7dd34071cb9cc2017a249a409394a03f6193.tar.bz2
gentoo-70ae7dd34071cb9cc2017a249a409394a03f6193.zip
app-mobilephone/gammu: remove virtual/mysql from deps
Replace virtual/mysql with dev-db/mysql-connector-c:= in dependencies. Closes: https://bugs.gentoo.org/665826 Closes: https://github.com/gentoo/gentoo/pull/9962 Signed-off-by: Victor Kustov <ktrace@yandex.ru> Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9962 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-mobilephone/gammu/gammu-1.39.0-r1.ebuild')
-rw-r--r--app-mobilephone/gammu/gammu-1.39.0-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-mobilephone/gammu/gammu-1.39.0-r1.ebuild b/app-mobilephone/gammu/gammu-1.39.0-r1.ebuild
new file mode 100644
index 000000000000..44f8382b7a3b
--- /dev/null
+++ b/app-mobilephone/gammu/gammu-1.39.0-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A tool to handle your cellular phone"
+HOMEPAGE="https://wammu.eu/gammu/"
+SRC_URI="https://dl.cihar.com/${PN}/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth curl dbi debug irda mysql nls odbc postgres usb"
+
+COMMON_DEPEND="
+ dev-libs/glib:2=
+ virtual/libgudev:=
+ bluetooth? ( net-wireless/bluez:= )
+ curl? ( net-misc/curl:= )
+ dbi? ( >=dev-db/libdbi-0.8.3:= )
+ mysql? ( dev-db/mysql-connector-c:= )
+ postgres? ( dev-db/postgresql:= )
+ usb? ( virtual/libusb:1= )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ irda? ( virtual/os-headers )
+ nls? ( sys-devel/gettext )
+ odbc? ( dev-db/unixODBC )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-util/dialog
+ virtual/libiconv
+"
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_BLUETOOTH=$(usex bluetooth)
+ -DWITH_CURL=$(usex curl)
+ -DWITH_Gettext=$(usex nls)
+ -DWITH_Iconv=$(usex nls)
+ -DWITH_IRDA=$(usex irda)
+ -DWITH_LibDBI=$(usex dbi)
+ -DWITH_MySQL=$(usex mysql)
+ -DWITH_ODBC=$(usex odbc)
+ -DWITH_Postgres=$(usex postgres)
+ -DWITH_USB=$(usex usb)
+ -DBUILD_SHARED_LIBS=ON
+ -DINSTALL_DOC_DIR="share/doc/${PF}"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ addwrite "/run/lock/LCK..bar"
+ LD_LIBRARY_PATH="${BUILD_DIR}/libgammu" cmake-utils_src_test -j1
+}