summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 20:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 19:42:20 +0100
commitbe0ab352405aa2d5d968a8c3905557b914df9626 (patch)
tree5b5da6a6ab8feb0c82b1f5c6b02e9fafdee83463 /app-mobilephone/gammu/gammu-1.41.0.ebuild
parentsys-kernel/gentoo-sources: Linux patch 5.4.7 (diff)
downloadgentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.gz
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.bz2
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.zip
*/*: Switch proxy-maint to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-mobilephone/gammu/gammu-1.41.0.ebuild')
-rw-r--r--app-mobilephone/gammu/gammu-1.41.0.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/app-mobilephone/gammu/gammu-1.41.0.ebuild b/app-mobilephone/gammu/gammu-1.41.0.ebuild
index 8be8100b03e1..2af395f25322 100644
--- a/app-mobilephone/gammu/gammu-1.41.0.ebuild
+++ b/app-mobilephone/gammu/gammu-1.41.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="A tool to handle your cellular phone"
HOMEPAGE="https://wammu.eu/gammu/"
@@ -45,18 +45,17 @@ src_configure() {
-DWITH_ODBC=$(usex odbc)
-DWITH_Postgres=$(usex postgres)
-DWITH_USB=$(usex usb)
- -DBUILD_SHARED_LIBS=ON
-DINSTALL_DOC_DIR="share/doc/${PF}"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
addwrite "/run/lock/LCK..bar"
- LD_LIBRARY_PATH="${BUILD_DIR}/libgammu" cmake-utils_src_test -j1
+ LD_LIBRARY_PATH="${BUILD_DIR}/libgammu" cmake_src_test -j1
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
docompress -x /usr/share/doc/${PF}/examples/
}