summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-mobilephone/yaps/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-mobilephone/yaps/files')
-rw-r--r--app-mobilephone/yaps/files/yaps-0.96-gentoo.diff56
-rw-r--r--app-mobilephone/yaps/files/yaps-0.96-getline-rename.patch64
-rw-r--r--app-mobilephone/yaps/files/yaps-0.96-string.patch10
3 files changed, 130 insertions, 0 deletions
diff --git a/app-mobilephone/yaps/files/yaps-0.96-gentoo.diff b/app-mobilephone/yaps/files/yaps-0.96-gentoo.diff
new file mode 100644
index 000000000000..c77bcd5d4912
--- /dev/null
+++ b/app-mobilephone/yaps/files/yaps-0.96-gentoo.diff
@@ -0,0 +1,56 @@
+--- a/Config
++++ b/Config
+@@ -24,9 +24,9 @@
+ # Name of local configuration file (location is $HOME.)
+ YAPS_LCFGFILE = .yapsrc
+ # Directory for installing the binary
+-YAPS_BINDIR = /usr/local/bin
++YAPS_BINDIR = /usr/bin
+ # Directory for optional support files
+-YAPS_LIBDIR = /usr/local/lib/yaps
++YAPS_LIBDIR = /usr/lib/yaps
+ # User/Group/Mode for yaps
+ YAPS_USER = bin
+ YAPS_GROUP = uucp
+@@ -43,12 +43,12 @@
+ ifdef SLANG
+ LDEFS += -DSCRIPT_SLANG
+ LLIBS += -lslang
+-MATH = True
++#MATH = True
+ endif
+ ifdef LUA
+ LDEFS += -DSCRIPT_LUA
+-LLIBS += -llualib -llua
+-MATH = True
++LLIBS += `pkg-config --libs lua`
++#MATH = True
+ endif
+ ifdef MATH
+ LLIBS += -lm
+--- a/Makefile
++++ b/Makefile
+@@ -33,19 +33,19 @@
+ lynx -cfg=/dev/null -nolist -dump $< > $@
+
+ install: $(DSTFLE) $(CFGFILE)
+- if [ ! -d $(YAPS_LIBDIR) ]; then \
+- install -d -m 755 -o $(YAPS_USER) -g $(YAPS_GROUP) $(YAPS_LIBDIR) ; \
++ if [ ! -d $(DESTDIR)$(YAPS_LIBDIR) ]; then \
++ install -d -m 755 $(DESTDIR)$(YAPS_LIBDIR) ; \
+ fi
+ @if [ -f contrib/Makefile ]; then \
+ $(MAKE) -C contrib install ; \
+ fi
+
+ $(DSTFLE): yaps
+- install -o $(YAPS_USER) -g $(YAPS_GROUP) -m $(YAPS_MODE) -s yaps $@
++ install -m $(YAPS_MODE) -s yaps $(DESTDIR)$@
+
+ $(CFGFILE): yaps.rc
+ @if [ ! -f $@ ]; then \
+- install -o $(YAPS_RCUSER) -g $(YAPS_RCGROUP) -m $(YAPS_RCMODE) -s yaps.rc $@ ; \
++ install -m $(YAPS_RCMODE) -s yaps.rc $(DESTDIR)$@ ; \
+ fi
+
+ clean:
diff --git a/app-mobilephone/yaps/files/yaps-0.96-getline-rename.patch b/app-mobilephone/yaps/files/yaps-0.96-getline-rename.patch
new file mode 100644
index 000000000000..2b76b5bb39e2
--- /dev/null
+++ b/app-mobilephone/yaps/files/yaps-0.96-getline-rename.patch
@@ -0,0 +1,64 @@
+--- a/cfg.c
++++ b/cfg.c
+@@ -203,7 +203,7 @@
+ fcur -> fp = fp;
+ fcur -> up = NULL;
+ while (fcur) {
+- while (gline = getline (fcur -> fp, True)) {
++ while (gline = my_getline (fcur -> fp, True)) {
+ for (line = gline; isspace (*line); ++line)
+ ;
+ if ((! *line) || (*line == '#')) {
+@@ -279,7 +279,7 @@
+ done = False;
+ siz = 0;
+ len = 0;
+- while (ptr = getline (fcur -> fp, False)) {
++ while (ptr = my_getline (fcur -> fp, False)) {
+ if ((*ptr != '}') || *(ptr + 1)) {
+ plen = strlen (ptr);
+ if (len + plen + 2 >= siz) {
+--- a/cv.c
++++ b/cv.c
+@@ -151,7 +151,7 @@
+ MCHK (c);
+ if ((! c) || (! (fp = fopen (fname, "r"))))
+ return -1;
+- while (line = getline (fp, True)) {
++ while (line = my_getline (fp, True)) {
+ for (sp = line; isspace (*sp); ++sp)
+ ;
+ if (*sp && (*sp != '#')) {
+--- a/pager.h
++++ b/pager.h
+@@ -67,7 +67,7 @@
+ /*{{{ utility */
+ extern char *skip (char *str);
+ extern char *skipch (char *str, char ch);
+-extern char *getline (FILE *fp, Bool cont);
++extern char *my_getline (FILE *fp, Bool cont);
+ extern int verbose_out (char *, ...);
+ /*}}}*/
+ /*{{{ string handling */
+--- a/util.c
++++ b/util.c
+@@ -36,7 +36,7 @@
+ }
+
+ char *
+-getline (FILE *fp, Bool cont)
++my_getline (FILE *fp, Bool cont)
+ {
+ char *buf;
+ int size;
+--- a/yaps.c
++++ b/yaps.c
+@@ -1177,7 +1177,7 @@
+ fprintf (stderr, "Unable to open message file %s for reading\n", mfile);
+ return NULL;
+ }
+- while (ptr = getline (fp, False)) {
++ while (ptr = my_getline (fp, False)) {
+ sav = skip (ptr);
+ if (*ptr && *sav) {
+ if (rcnt + 2 >= rsiz) {
diff --git a/app-mobilephone/yaps/files/yaps-0.96-string.patch b/app-mobilephone/yaps/files/yaps-0.96-string.patch
new file mode 100644
index 000000000000..6641e2f7d4e3
--- /dev/null
+++ b/app-mobilephone/yaps/files/yaps-0.96-string.patch
@@ -0,0 +1,10 @@
+--- a/scr.c
++++ b/scr.c
+@@ -2,6 +2,7 @@
+ # include "config.h"
+ # include <stdio.h>
+ # include <stdlib.h>
++# include <string.h>
+ # include "pager.h"
+ # include "script.h"
+