summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuje Mihanović <duje.mihanovic@skole.hr>2023-09-18 16:43:44 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-09-18 19:39:49 +0300
commitd94889dd200f7c2e018360dc982ffce12416247a (patch)
tree6de1794cfec21057bb5fecbfde0fcfc8fa8adf47 /app-mobilephone
parentsys-power/tlp: retire duje.mihanovic (diff)
downloadgentoo-d94889dd200f7c2e018360dc982ffce12416247a.tar.gz
gentoo-d94889dd200f7c2e018360dc982ffce12416247a.tar.bz2
gentoo-d94889dd200f7c2e018360dc982ffce12416247a.zip
app-mobilephone/heimdall: 2.0.2 version bump
Closes: https://bugs.gentoo.org/914090 Signed-off-by: Duje Mihanović <duje.mihanovic@skole.hr> Closes: https://github.com/gentoo/gentoo/pull/32904 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/heimdall/Manifest1
-rw-r--r--app-mobilephone/heimdall/heimdall-2.0.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-mobilephone/heimdall/Manifest b/app-mobilephone/heimdall/Manifest
index 3580a15056fb..e9a2e5b5577c 100644
--- a/app-mobilephone/heimdall/Manifest
+++ b/app-mobilephone/heimdall/Manifest
@@ -1 +1,2 @@
DIST heimdall-2.0.1.tar.gz 83642 BLAKE2B 29cd784a4ea4c25f9670d27c306ca95d60d7ad8a11175d2ee835a0cf1e7fc5eb179aa4e49c5e05e280ed5ce475a9e66e56b48444dd4b3b93ea8cb173e3d18060 SHA512 f6df4551702a7ad7688018d60569b8b94f20be4f78a9b4bf5f6e89396ed43cd7519617ef1f420b41bbfeec8b51ae636759a7b90443d3d5945cd8744b43e2d0ef
+DIST heimdall-2.0.2.tar.gz 83619 BLAKE2B 783f94243730a53f25e8d6d95b4c0839d727a5290aed72948fa7e7a3f4217b3ef1cbfc5e3cd828642d0eb5e965b153097d9dfde11d6fcec2066364a444899f41 SHA512 62849bfe7550214dd774efea65169673fa916f9d204000f793d995aed9def95fcc895c8913cd648f2397ab7fd154257e0394b78c180ed60d043c75858bac7c0a
diff --git a/app-mobilephone/heimdall/heimdall-2.0.2.ebuild b/app-mobilephone/heimdall/heimdall-2.0.2.ebuild
new file mode 100644
index 000000000000..b1c61d9f7b06
--- /dev/null
+++ b/app-mobilephone/heimdall/heimdall-2.0.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake udev
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://git.sr.ht/~grimler/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~arm64"
+ S="${WORKDIR}/Heimdall-v${PV}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~grimler/Heimdall"
+fi
+
+DESCRIPTION="Tool suite used to flash firmware onto Samsung devices"
+HOMEPAGE="https://git.sr.ht/~grimler/Heimdall https://glassechidna.com.au/heimdall/ https://github.com/Benjamin-Dobell/Heimdall"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="gui"
+
+RDEPEND="
+ sys-libs/zlib
+ virtual/libusb:1=
+ gui? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_FRONTEND=$(usex !gui)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}"/bin/heimdall
+ use gui && dobin "${BUILD_DIR}"/bin/heimdall-frontend
+ udev_dorules heimdall/60-heimdall.rules
+ dodoc README.md Linux/README
+}
+
+pkg_postinst() {
+ udev_reload
+}