summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-11-14 22:51:09 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-11-14 22:51:22 +0100
commitb27ba258bb433dd53096df03297c04c1c5cbd6a8 (patch)
treea9bab9f7dc5119c1745bcfccac878b85b99c210a /app-office/calcurse/calcurse-4.3.0.ebuild
parentsys-apps/openrc: x86 stable (bug #637508) (diff)
downloadgentoo-b27ba258bb433dd53096df03297c04c1c5cbd6a8.tar.gz
gentoo-b27ba258bb433dd53096df03297c04c1c5cbd6a8.tar.bz2
gentoo-b27ba258bb433dd53096df03297c04c1c5cbd6a8.zip
app-office/calcurse: version bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-office/calcurse/calcurse-4.3.0.ebuild')
-rw-r--r--app-office/calcurse/calcurse-4.3.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-office/calcurse/calcurse-4.3.0.ebuild b/app-office/calcurse/calcurse-4.3.0.ebuild
new file mode 100644
index 000000000000..2ae42b684376
--- /dev/null
+++ b/app-office/calcurse/calcurse-4.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="a text-based calendar and scheduling application"
+HOMEPAGE="http://calcurse.org/"
+SRC_URI="http://calcurse.org/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc ~ppc64"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+
+# Most tests fail.
+RESTRICT="test"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+src_compile() {
+ multilib-minimal_src_compile
+}
+
+src_install() {
+ multilib-minimal_src_install
+}