summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-01-04 14:27:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-01-06 23:30:32 +0100
commit40af205e956491a6115c088a186080f63b84a9d4 (patch)
treea7695cc6faa39ae46fcc7a123a018506cd31f3ba /app-office/calligra/files
parentdev-php/twig: don't run eclass phases when USE="extension" is unset. (diff)
downloadgentoo-40af205e956491a6115c088a186080f63b84a9d4.tar.gz
gentoo-40af205e956491a6115c088a186080f63b84a9d4.tar.bz2
gentoo-40af205e956491a6115c088a186080f63b84a9d4.zip
app-office/calligra: Fix DEPENDs, add USE=jpeg2k,phonon
Make USE=lcms do something (enable PLUGIN_COLORENGINES) Make USE=spacenav do sth (enable PLUGIN_SPACENAVIGATOR) Revert upstream disabling AkonadiContact Block calligra-l10n:4 Drop unused libpng dependency Move boost,threadweaver RDEPEND -> DEPEND KDE_TEST=forceoptional-recursive to eliminate a truckload of warnings Disable benchmarks as well, nothing is installed Patch out bogus references to kdelibs4 Package-Manager: portage-2.3.0
Diffstat (limited to 'app-office/calligra/files')
-rw-r--r--app-office/calligra/files/calligra-3.0.0.1-deps1.patch31
-rw-r--r--app-office/calligra/files/calligra-3.0.0.1-deps2.patch65
-rw-r--r--app-office/calligra/files/calligra-3.0.0.1-deps3.patch31
-rw-r--r--app-office/calligra/files/calligra-3.0.0.1-nokdelibs4.patch38
-rw-r--r--app-office/calligra/files/calligra-3.0.0.1-reenable-akonadi.patch113
-rw-r--r--app-office/calligra/files/calligra-3.0.0.1-relax-deps.patch34
6 files changed, 312 insertions, 0 deletions
diff --git a/app-office/calligra/files/calligra-3.0.0.1-deps1.patch b/app-office/calligra/files/calligra-3.0.0.1-deps1.patch
new file mode 100644
index 000000000000..9ee98ffff6cb
--- /dev/null
+++ b/app-office/calligra/files/calligra-3.0.0.1-deps1.patch
@@ -0,0 +1,31 @@
+commit 3e3c3a16b9a8b114cc407da9152e20d5dfc422c6
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Wed Jan 4 14:10:56 2017 +0100
+
+ Make Activities and KF5Html really optional.
+
+ Before, trying to use CMAKE_DISABLE_FIND_PACKAGE_KF5{Activities,KHtml}
+ errored out with:
+
+ "if given arguments: "VERSION_LESS" "5.16.0" Unknown arguments specified"
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0394af4..e11d998 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -223,11 +223,10 @@ find_package(KF5 ${REQUIRED_KF5_VERSION} REQUIRED
+ Notifications
+ KCMUtils
+ )
+-find_package(KF5 ${REQUIRED_KF5_VERSION} QUIET
+- OPTIONAL_COMPONENTS
+- Activities
+- KHtml
+-)
++
++find_package(KF5Activities)
++find_package(KF5KHtml)
++
+ set_package_properties(KF5Activities PROPERTIES
+ TYPE OPTIONAL
+ )
diff --git a/app-office/calligra/files/calligra-3.0.0.1-deps2.patch b/app-office/calligra/files/calligra-3.0.0.1-deps2.patch
new file mode 100644
index 000000000000..c0e3587aee64
--- /dev/null
+++ b/app-office/calligra/files/calligra-3.0.0.1-deps2.patch
@@ -0,0 +1,65 @@
+commit 511d4014beff9f79aeab1c0013470f21ac6b7df7
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Wed Jan 4 14:13:19 2017 +0100
+
+ Fix dependencies, sort and clean trailing whitespaces
+
+ Add missing KF5JobWidgets
+ Drop unused KF5TextEditor
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e11d998..6fab26b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -195,33 +195,33 @@ set(REQUIRED_KF5_VERSION "5.7.0")
+
+ find_package(KF5 ${REQUIRED_KF5_VERSION} REQUIRED
+ COMPONENTS
+- Archive
+- Codecs
++ Archive
++ Codecs
+ Completion
+- Config
+- ConfigWidgets
++ Config
++ ConfigWidgets
+ CoreAddons
+ DBusAddons
+ DocTools
+- GuiAddons
+- I18n
+- IconThemes
++ GuiAddons
++ I18n
++ IconThemes
+ ItemViews
++ JobWidgets
++ KCMUtils
+ KDELibs4Support
+- KIO
+- Kross
+- Parts
++ KIO
++ Kross
++ Notifications
++ NotifyConfig
++ Parts
+ Sonnet
+- TextEditor
+- TextWidgets
++ TextWidgets
+ ThreadWeaver
+- Wallet
+- WidgetsAddons
++ Wallet
++ WidgetsAddons
+ WindowSystem
+- XmlGui
+- NotifyConfig
+- Notifications
+- KCMUtils
++ XmlGui
+ )
+
+ find_package(KF5Activities)
diff --git a/app-office/calligra/files/calligra-3.0.0.1-deps3.patch b/app-office/calligra/files/calligra-3.0.0.1-deps3.patch
new file mode 100644
index 000000000000..24591789763c
--- /dev/null
+++ b/app-office/calligra/files/calligra-3.0.0.1-deps3.patch
@@ -0,0 +1,31 @@
+commit 019f7e77a341661742b179c92cbce485b7ae361e
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Wed Jan 4 23:51:32 2017 +0100
+
+ Push KF5Threadweaver dep to the only place where it is used
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6fab26b..ace6f52 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -217,7 +217,6 @@ find_package(KF5 ${REQUIRED_KF5_VERSION} REQUIRED
+ Parts
+ Sonnet
+ TextWidgets
+- ThreadWeaver
+ Wallet
+ WidgetsAddons
+ WindowSystem
+diff --git a/libs/widgets/tests/CMakeLists.txt b/libs/widgets/tests/CMakeLists.txt
+index 3934630..744828c 100644
+--- a/libs/widgets/tests/CMakeLists.txt
++++ b/libs/widgets/tests/CMakeLists.txt
+@@ -4,6 +4,8 @@ include_directories( ${KOMAIN_INCLUDES} ${CMAKE_SOURCE_DIR}/libs/widgets)
+ add_definitions(-DFILES_DATA_DIR="${CMAKE_CURRENT_SOURCE_DIR}/data/")
+ add_definitions(-DFILES_OUTPUT_DIR="${CMAKE_CURRENT_BINARY_DIR}")
+
++find_package(KF5ThreadWeaver ${REQUIRED_KF5_VERSION} REQUIRED)
++
+ #add_subdirectory(filedialogtester)
+
+ # call: kowidgets_add_unit_test(<test-name> <sources> LINK_LIBRARIES <library> [<library> [...]] [GUI])
diff --git a/app-office/calligra/files/calligra-3.0.0.1-nokdelibs4.patch b/app-office/calligra/files/calligra-3.0.0.1-nokdelibs4.patch
new file mode 100644
index 000000000000..faf4c87f2476
--- /dev/null
+++ b/app-office/calligra/files/calligra-3.0.0.1-nokdelibs4.patch
@@ -0,0 +1,38 @@
+commit 8d2383d29beaaad1ebb0b9de2b73589a8b964cdc
+Author: Dag Andersen <danders@get2net.dk>
+Date: Thu Jan 5 09:32:12 2017 +0100
+
+ Plan does not depend on Kdelibs4Support
+
+diff --git a/plan/libs/kernel/CMakeLists.txt b/plan/libs/kernel/CMakeLists.txt
+index d85b537..fddb9c3 100644
+--- a/plan/libs/kernel/CMakeLists.txt
++++ b/plan/libs/kernel/CMakeLists.txt
+@@ -45,8 +45,6 @@ target_link_libraries(kplatokernel
+ kowidgetutils
+ kundo2
+ KF5::KIOWidgets
+- PRIVATE
+- KF5::KDELibs4Support
+ )
+
+ set_target_properties(kplatokernel PROPERTIES VERSION ${GENERIC_CALLIGRA_LIB_VERSION} SOVERSION ${GENERIC_CALLIGRA_LIB_SOVERSION} )
+commit 3a3ee7863b65313f573593bf868584f829b725f2
+Author: Dag Andersen <danders@get2net.dk>
+Date: Thu Jan 5 12:15:04 2017 +0100
+
+ Plan: klocale.h is from kde4, so remove
+
+diff --git a/plan/libs/kernel/kptlocale.cpp b/plan/libs/kernel/kptlocale.cpp
+index 6bfc7d8..2145f7c 100644
+--- a/plan/libs/kernel/kptlocale.cpp
++++ b/plan/libs/kernel/kptlocale.cpp
+@@ -22,8 +22,6 @@
+
+ #include "kptdebug.h"
+
+-#include <klocale.h>
+-
+ #include <QLocale>
+
+
diff --git a/app-office/calligra/files/calligra-3.0.0.1-reenable-akonadi.patch b/app-office/calligra/files/calligra-3.0.0.1-reenable-akonadi.patch
new file mode 100644
index 000000000000..0ce83b61efa6
--- /dev/null
+++ b/app-office/calligra/files/calligra-3.0.0.1-reenable-akonadi.patch
@@ -0,0 +1,113 @@
+commit b8de9669eab6487387d76e3181e0d38df46205a5
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Wed Jan 4 13:55:13 2017 +0100
+
+ Revert "Workaround bug 311940: Plan crashes when typing a text in..."
+
+ "...the filter textbox before the textbook is fully loaded when selecting
+ a contact from the adressbook"
+
+ This reverts commit
+ 1fb81d2e5fc2df149261c6fc20a13b4a6a03dd7a
+ and partially
+ b8d7a4034e5e85577e8a7eff523c226ca2d965c5
+
+diff --git a/plan/CMakeLists.txt b/plan/CMakeLists.txt
+index 25427da..119b23c 100644
+--- a/plan/CMakeLists.txt
++++ b/plan/CMakeLists.txt
+@@ -5,10 +5,7 @@ project(kplato)
+ add_definitions( -DKDE_DEFAULT_DEBUG_AREA=42000 )
+
+ if (KF5AkonadiContact_FOUND)
+- # disable for now: there is a bug
+- # it only works if you use kde contacts (of course) but many use other stuff, so gets dissapointed
+- # add_definitions(-DPLAN_KDEPIMLIBS_FOUND)
+- message(WARNING "AkonadiContacs available, but funtion is disabled due to Bug 311940")
++ add_definitions(-DPLAN_KDEPIMLIBS_FOUND)
+ endif ()
+
+ if (PLANCHARTDEBUG)
+@@ -25,6 +22,7 @@ set( KPLATO_INCLUDES
+ ${CMAKE_BINARY_DIR}/plan
+
+ ${KOMAIN_INCLUDES}
++ ${KDEPIMLIBS_INCLUDE_DIR}
+ )
+
+ add_subdirectory( libs )
+diff --git a/plan/kpttaskdefaultpanel.cpp b/plan/kpttaskdefaultpanel.cpp
+index 27eca57..6f119e5 100644
+--- a/plan/kpttaskdefaultpanel.cpp
++++ b/plan/kpttaskdefaultpanel.cpp
+@@ -55,10 +55,6 @@ ConfigTaskPanelImpl::ConfigTaskPanelImpl(QWidget *p )
+ chooseLeader->hide();
+ #endif
+
+- // FIXME
+- // [Bug 311940] New: Plan crashes when typing a text in the filter textbox before the textbook is fully loaded when selecting a contact from the adressbook
+- chooseLeader->hide();
+-
+ initDescription();
+
+ connect(chooseLeader, SIGNAL(clicked()), SLOT(changeLeader()));
+diff --git a/plan/libs/ui/kptmainprojectpanel.cpp b/plan/libs/ui/kptmainprojectpanel.cpp
+index ac7212b..2078d4d 100644
+--- a/plan/libs/ui/kptmainprojectpanel.cpp
++++ b/plan/libs/ui/kptmainprojectpanel.cpp
+@@ -48,10 +48,6 @@ MainProjectPanel::MainProjectPanel(Project &p, QWidget *parent)
+ chooseLeader->hide();
+ #endif
+
+- // FIXME
+- // [Bug 311940] New: Plan crashes when typing a text in the filter textbox before the textbook is fully loaded when selecting a contact from the adressbook
+- chooseLeader->hide();
+-
+ QString s = i18n( "The Work Breakdown Structure introduces numbering for all tasks in the project, according to the task structure.\nThe WBS code is auto-generated.\nYou can define the WBS code pattern using the Define WBS Pattern command in the Tools menu." );
+ wbslabel->setWhatsThis( s );
+ wbs->setWhatsThis( s );
+diff --git a/plan/libs/ui/kptresourcedialog.cpp b/plan/libs/ui/kptresourcedialog.cpp
+index 5e092c4..ff9eae0 100644
+--- a/plan/libs/ui/kptresourcedialog.cpp
++++ b/plan/libs/ui/kptresourcedialog.cpp
+@@ -53,10 +53,6 @@ ResourceDialogImpl::ResourceDialogImpl( const Project &project, Resource &resour
+ chooseBtn->hide();
+ #endif
+
+- // FIXME
+- // [Bug 311940] New: Plan crashes when typing a text in the filter textbox before the textbook is fully loaded when selecting a contact from the adressbook
+- chooseBtn->hide();
+-
+ QSortFilterProxyModel *pr = new QSortFilterProxyModel( ui_teamView );
+ QStandardItemModel *m = new QStandardItemModel( ui_teamView );
+ pr->setSourceModel( new QStandardItemModel( ui_teamView ) );
+diff --git a/plan/libs/ui/kptsummarytaskgeneralpanel.cpp b/plan/libs/ui/kptsummarytaskgeneralpanel.cpp
+index 1a2af87..dd66ca8 100644
+--- a/plan/libs/ui/kptsummarytaskgeneralpanel.cpp
++++ b/plan/libs/ui/kptsummarytaskgeneralpanel.cpp
+@@ -45,10 +45,6 @@ SummaryTaskGeneralPanel::SummaryTaskGeneralPanel(Task &task, QWidget *p, const c
+ chooseLeader->hide();
+ #endif
+
+- // FIXME
+- // [Bug 311940] New: Plan crashes when typing a text in the filter textbox before the textbook is fully loaded when selecting a contact from the adressbook
+- chooseLeader->hide();
+-
+ m_description = new TaskDescriptionPanel( task, this );
+ m_description->namefield->hide();
+ m_description->namelabel->hide();
+diff --git a/plan/libs/ui/kpttaskgeneralpanel.cpp b/plan/libs/ui/kpttaskgeneralpanel.cpp
+index b3c2974..562ea9d 100644
+--- a/plan/libs/ui/kpttaskgeneralpanel.cpp
++++ b/plan/libs/ui/kpttaskgeneralpanel.cpp
+@@ -228,10 +228,6 @@ TaskGeneralPanelImpl::TaskGeneralPanelImpl(QWidget *p, const char *n)
+ chooseLeader->hide();
+ #endif
+
+- // FIXME
+- // [Bug 311940] New: Plan crashes when typing a text in the filter textbox before the textbook is fully loaded when selecting a contact from the adressbook
+- chooseLeader->hide();
+-
+ connect(namefield, SIGNAL(textChanged(QString)), SLOT(checkAllFieldsFilled()));
+ connect(leaderfield, SIGNAL(textChanged(QString)), SLOT(checkAllFieldsFilled()));
+ connect(chooseLeader, SIGNAL(clicked()), SLOT(changeLeader()));
diff --git a/app-office/calligra/files/calligra-3.0.0.1-relax-deps.patch b/app-office/calligra/files/calligra-3.0.0.1-relax-deps.patch
new file mode 100644
index 000000000000..3eeb557239e6
--- /dev/null
+++ b/app-office/calligra/files/calligra-3.0.0.1-relax-deps.patch
@@ -0,0 +1,34 @@
+From c769476b16068a82c20e195134e7c32ae7c7a081 Mon Sep 17 00:00:00 2001
+From: Dag Andersen <danders@get2net.dk>
+Date: Thu, 5 Jan 2017 12:51:26 +0100
+Subject: We should accept all 3.0 versions of KReport/KProperty
+
+---
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4de94a4..f963bde 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -480,7 +480,7 @@ set_package_properties(KChart PROPERTIES
+ ##
+ ## Test for KReport
+ ##
+-macro_optional_find_package(KReport 3.0.0 EXACT QUIET)
++macro_optional_find_package(KReport 3.0 QUIET)
+ set_package_properties(KReport PROPERTIES
+ DESCRIPTION "A framework for the creation and generation of reports in multiple formats"
+ URL "https://community.kde.org/KReport"
+@@ -491,7 +491,7 @@ set_package_properties(KReport PROPERTIES
+ ##
+ ## Test for KPropertyWidgets
+ ##
+-macro_optional_find_package(KPropertyWidgets 3.0.0 EXACT QUIET)
++macro_optional_find_package(KPropertyWidgets 3.0 QUIET)
+ set_package_properties(KPropertyWidgets PROPERTIES
+ DESCRIPTION "A property editing framework with editor widget"
+ URL "https://community.kde.org/KProperty"
+--
+cgit v0.11.2
+