summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/dia/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/dia/files')
-rw-r--r--app-office/dia/files/dia-0.97.0-gnome-doc.patch61
-rw-r--r--app-office/dia/files/dia-0.97.2-disable-cairo.patch19
-rw-r--r--app-office/dia/files/dia-0.97.2-png-crash.patch33
-rw-r--r--app-office/dia/files/dia-0.97.2-underlinking.patch27
4 files changed, 140 insertions, 0 deletions
diff --git a/app-office/dia/files/dia-0.97.0-gnome-doc.patch b/app-office/dia/files/dia-0.97.0-gnome-doc.patch
new file mode 100644
index 000000000000..63e13deaf22f
--- /dev/null
+++ b/app-office/dia/files/dia-0.97.0-gnome-doc.patch
@@ -0,0 +1,61 @@
+From 9d40692b695b30f80b263814bdd351c0dbe67733 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Mon, 18 May 2009 22:19:35 +0200
+Subject: [PATCH] Fix compilation in a gnome environment, gentoo bug #159831
+
+---
+ configure.in | 19 +++++++++++--------
+ 1 files changed, 11 insertions(+), 8 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index d27ee6e..d9c0bf4 100644
+--- a/configure.in
++++ b/configure.in
+@@ -110,17 +110,19 @@ if test "$have_libart" = "yes" ; then
+ fi
+
+ AC_MSG_CHECKING([whether GNOME specific code should be used])
+-AC_ARG_ENABLE(gnome,[ --enable-gnome enable gnome code],
+- GNOME=$enableval, GNOME=no)
+-if test "$GNOME" = "yes" ; then
++AC_ARG_ENABLE(gnome,
++ AC_HELP_STRING([--enable-gnome],[enable gnome code]),,
++ enable_gnome=no)
++if test "x$enable_gnome" = "xyes" ; then
+ GTK_MODULES="$GTK_MODULES libgnome-2.0 libgnomeui-2.0"
+ AC_DEFINE(GNOME,1,[Define if building with GNOME support])
++ AC_DEFINE(HAVE_GNOME,1,[Define if building with GNOME support])
+ AC_DEFINE_UNQUOTED(GNOME_ICONDIR, "${prefix}/share/pixmaps", [GNOME icon directory])
+- have_gnome=true
++ have_gnome=yes
+ else
+- have_gnome=false
++ have_gnome=no
+ fi
+-AM_CONDITIONAL(HAVE_GNOME, $have_gnome)
++AM_CONDITIONAL(HAVE_GNOME, [test "x$have_gnome" != "xno"])
+ AC_MSG_RESULT($GNOME)
+
+ dnl GTK2: libgnomecanvas-2.0 ?
+@@ -129,7 +131,8 @@ PKG_CHECK_MODULES(GTK,$GTK_MODULES)
+ AC_SUBST(GTK_CFLAGS)
+ AC_SUBST(GTK_LIBS)
+
+-AM_CONDITIONAL(HAVE_BONOBO,false)
++#AM_CONDITIONAL(HAVE_BONOBO,false)
++AM_CONDITIONAL(HAVE_BONOBO,[test "true" = "false"])
+
+ dnl Look for Cairo
+ AC_ARG_WITH(cairo,
+@@ -627,7 +630,7 @@ Configuration:
+ Source code location: ${srcdir}
+ Compiler: ${CC}
+
+- Gnome support: ${GNOME}
++ Gnome support: ${have_gnome}
+ Python support: ${with_python}
+ Libart support (PNG export): ${have_libart}
+ Cairo support (PNG, PDF, print): ${with_cairo}
+--
+1.6.3
+
diff --git a/app-office/dia/files/dia-0.97.2-disable-cairo.patch b/app-office/dia/files/dia-0.97.2-disable-cairo.patch
new file mode 100644
index 000000000000..da07337825e9
--- /dev/null
+++ b/app-office/dia/files/dia-0.97.2-disable-cairo.patch
@@ -0,0 +1,19 @@
+--- plug-ins/cairo/Makefile.am.orig 2014-05-06 14:09:36.080876942 -0400
++++ plug-ins/cairo/Makefile.am 2014-05-06 14:11:21.043041750 -0400
+@@ -1,11 +1,14 @@
+-
++if WITH_CAIRO
+ plugin_sources = \
+ diacairo.c \
+ diacairo.h \
+ diacairo-interactive.c \
+ diacairo-renderer.c \
+ diacairo-print.c \
+- diacairo-print.h
++ diacairo-print.h
++else
++plugin_sources =
++endif
+
+ pkglib_LTLIBRARIES = libcairo_filter.la
+
diff --git a/app-office/dia/files/dia-0.97.2-png-crash.patch b/app-office/dia/files/dia-0.97.2-png-crash.patch
new file mode 100644
index 000000000000..1dfc072c1c5f
--- /dev/null
+++ b/app-office/dia/files/dia-0.97.2-png-crash.patch
@@ -0,0 +1,33 @@
+From 8b8ae09fcc16cc0522679099728f779e291d959c Mon Sep 17 00:00:00 2001
+From: Hans Breuer <hans@breuer.org>
+Date: Fri, 18 Apr 2014 13:28:45 +0200
+Subject: Bug 728405 - back-port some bounding box calculation fixes from
+ master
+
+... so that the unit test works without complaints.
+
+diff --git a/lib/boundingbox.c b/lib/boundingbox.c
+index fd50da7..46adbfa 100644
+--- a/lib/boundingbox.c
++++ b/lib/boundingbox.c
+@@ -494,7 +494,7 @@ polybezier_bbox(const BezPoint *pts, int numpoints,
+ account with the "pointy corners" X (and PS) add when LINEJOIN_MITER mode is
+ in force. */
+
+- if ((!start) && (!end)) { /* We have a non-extremity vertex. */
++ if (!end) { /* only the last segment might not produce overshoot. */
+ Point vpx,vxn;
+ real co,alpha;
+
+@@ -515,7 +515,7 @@ polybezier_bbox(const BezPoint *pts, int numpoints,
+ real overshoot;
+ Point vovs,pto;
+
+- if (finite(alpha))
++ if (alpha > 0.0 && alpha < M_PI)
+ overshoot = extra->middle_trans / sin(alpha/2.0);
+ else /* prependicular? */
+ overshoot = extra->middle_trans;
+--
+cgit v0.10.1
+
diff --git a/app-office/dia/files/dia-0.97.2-underlinking.patch b/app-office/dia/files/dia-0.97.2-underlinking.patch
new file mode 100644
index 000000000000..903e077f23f4
--- /dev/null
+++ b/app-office/dia/files/dia-0.97.2-underlinking.patch
@@ -0,0 +1,27 @@
+From 2f853bab67b087605a10f544a7df780ac98b8583 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <gentoo@mgorny.alt.pl>
+Date: Sat, 7 Jul 2012 17:28:59 +0200
+Subject: [PATCH] Fix missing linkage with gmodule-2.0.
+
+Fixes: https://bugzilla.gnome.org/show_bug.cgi?id=678761
+Fixes: https://bugs.gentoo.org/show_bug.cgi?id=420685
+---
+ dia-0.97.2/configure.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/dia-0.97.2/configure.in b/dia-0.97.2/configure.in
+index 72830de..6b7394a 100644
+--- a/dia-0.97.2/configure.in
++++ b/dia-0.97.2/configure.in
+@@ -55,7 +55,7 @@ AC_SUBST(GMODULE_CFLAGS)
+ AC_SUBST(GMODULE_LIBS)
+ AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
+
+-GTK_MODULES="gtk+-2.0 >= 2.6.0 glib-2.0 >= 2.6.0 libxml-2.0 gdk-pixbuf-2.0 gthread-2.0"
++GTK_MODULES="gtk+-2.0 >= 2.6.0 glib-2.0 >= 2.6.0 libxml-2.0 gdk-pixbuf-2.0 gthread-2.0 gmodule-2.0"
+ PKG_CHECK_MODULES(PANGOVERSION, pango >= 1.8.0, ,
+ AC_MSG_ERROR([Need Pango version 1.8.0 or higher]))
+
+--
+1.7.11.1
+