summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-15 15:43:53 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-15 15:52:05 -0400
commit5954d434790d108ff0e879a55bbebc740098e64b (patch)
treef5ec4ff3c5f4e6305fa629a1984560b83b26a2a8 /app-office/endeavour
parentgui-libs/libadwaita: Version bump to 1.2.0 (diff)
downloadgentoo-5954d434790d108ff0e879a55bbebc740098e64b.tar.gz
gentoo-5954d434790d108ff0e879a55bbebc740098e64b.tar.bz2
gentoo-5954d434790d108ff0e879a55bbebc740098e64b.zip
app-office/endeavour: Move from app-office/gnome-todo
And at the same time * Add v42.0 * Drop v3.28 * Update 9999 ebuild Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-office/endeavour')
-rw-r--r--app-office/endeavour/Manifest1
-rw-r--r--app-office/endeavour/endeavour-42.0.ebuild75
-rw-r--r--app-office/endeavour/endeavour-9999.ebuild62
-rw-r--r--app-office/endeavour/files/42.0-build-Generate-enum-headers-first.patch84
-rw-r--r--app-office/endeavour/metadata.xml8
5 files changed, 230 insertions, 0 deletions
diff --git a/app-office/endeavour/Manifest b/app-office/endeavour/Manifest
new file mode 100644
index 000000000000..689910024e6c
--- /dev/null
+++ b/app-office/endeavour/Manifest
@@ -0,0 +1 @@
+DIST Endeavour-v42.0.tar.bz2 606645 BLAKE2B f9575eeaa67f837e465cbf8e8790a477c299bea12410ceda3c1f9ab5df69948087c7c8679cee5651eac828b69fe64f2b22ff759c2174f044166b94a25270668c SHA512 6312bad832f864adc3e4e01112efccb9c867b31485460791a1d1cf0d515586e7fdb7dd9dca3790201f764b72c39cff69626794f7020b4b084034fdbd0e07d94a
diff --git a/app-office/endeavour/endeavour-42.0.ebuild b/app-office/endeavour/endeavour-42.0.ebuild
new file mode 100644
index 000000000000..cb393edc681b
--- /dev/null
+++ b/app-office/endeavour/endeavour-42.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Personal task manager"
+HOMEPAGE="https://wiki.gnome.org/Apps/Todo https://gitlab.gnome.org/World/Endeavour"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/World/Endeavour.git"
+ SRC_URI=""
+else
+ SRC_URI="https://gitlab.gnome.org/World/${PN^}/-/archive/v${PV}/${PN^}-v${PV}.tar.bz2"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN^}-v${PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+introspection"
+RESTRICT="test" # Tests are broken in 42.0
+
+RDEPEND="
+ >=dev-libs/glib-2.58.0:2
+ >=gui-libs/gtk-3.92.0:4[introspection?]
+ >=gui-libs/libadwaita-1.2.0:1
+ >=net-libs/gnome-online-accounts-3.25.3:=
+ >=dev-libs/libpeas-1.17
+ dev-libs/libportal:0=[gtk]
+ >=gnome-extra/evolution-data-server-3.33.2:=[gtk]
+ net-libs/rest:0.7
+ dev-libs/json-glib
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-build-Generate-enum-headers-first.patch
+)
+
+src_configure() {
+ # TODO: There aren't any consumers of the introspection outside gnome-todo's own plugins, so maybe we
+ # TODO: should just always build introspection support as an application that needs it for full functionality?
+ # Todoist plugin requires 3.25.3 GOA for being able to add a Todoist account
+ local emesonargs=(
+ $(meson_use introspection)
+ -Dtracing=false
+ -Dprofile=default
+
+ -Dtodo_txt_plugin=true
+ -Dtodoist_plugin=true
+ -Dunscheduled_panel_plugin=true
+ -Dbackground_plugin=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-office/endeavour/endeavour-9999.ebuild b/app-office/endeavour/endeavour-9999.ebuild
new file mode 100644
index 000000000000..97a763cfccef
--- /dev/null
+++ b/app-office/endeavour/endeavour-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Personal task manager"
+HOMEPAGE="https://wiki.gnome.org/Apps/Todo https://gitlab.gnome.org/World/Endeavour"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/World/Endeavour.git"
+ SRC_URI=""
+else
+ SRC_URI="https://gitlab.gnome.org/World/${PN^}/-/archive/v${PV}/${PN^}-v${PV}.tar.bz2"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN^}-v${PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.58.0:2
+ >=gui-libs/gtk-3.92.0:4[introspection?]
+ >=gui-libs/libadwaita-1.2.0:1
+ >=net-libs/gnome-online-accounts-3.2.0:=
+ >=dev-libs/libpeas-1.17
+ dev-libs/libportal:0=[gtk]
+ >=gnome-extra/evolution-data-server-3.33.2:=[gtk]
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # TODO: There aren't any consumers of the introspection outside gnome-todo's own plugins, so maybe we
+ # TODO: should just always build introspection support as an application that needs it for full functionality?
+ local emesonargs=(
+ $(meson_use introspection)
+ -Dtracing=false
+ -Dprofile=default
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-office/endeavour/files/42.0-build-Generate-enum-headers-first.patch b/app-office/endeavour/files/42.0-build-Generate-enum-headers-first.patch
new file mode 100644
index 000000000000..6efa26dead2c
--- /dev/null
+++ b/app-office/endeavour/files/42.0-build-Generate-enum-headers-first.patch
@@ -0,0 +1,84 @@
+From b492285e2a4fafad887df2c4fd2a5bdb53ce39fb Mon Sep 17 00:00:00 2001
+From: Jamie Murphy <hello@itsjamie.dev>
+Date: Fri, 5 Aug 2022 18:52:20 -0700
+Subject: [PATCH] build: Generate enum headers first
+
+Fixes #380, #398, !120, !110
+---
+ src/meson.build | 38 +++++++++++++++++++-------------------
+ src/plugins/meson.build | 3 ++-
+ 2 files changed, 21 insertions(+), 20 deletions(-)
+
+diff --git a/src/meson.build b/src/meson.build
+index deb410a2..8f621e78 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -16,6 +16,25 @@ vcs_identifier_h = declare_dependency(sources: vcs_tag)
+
+ endeavour_deps += vcs_identifier_h
+
++#########
++# Enums #
++#########
++
++enum_headers = files(
++ join_paths('animation', 'gtd-animation-enums.h'),
++)
++
++enum_types = 'gtd-enum-types'
++
++gtd_enum_types = gnome.mkenums(
++ enum_types,
++ sources: enum_headers,
++ c_template: enum_types + '.c.template',
++ h_template: enum_types + '.h.template'
++)
++
++sources += gtd_enum_types
++
+ ###########
+ # Plugins #
+ ###########
+@@ -42,25 +61,6 @@ gtd_deps = endeavour_deps + [
+ plugins_dep,
+ ]
+
+-
+-#########
+-# Enums #
+-#########
+-
+-enum_headers = files(
+- join_paths('animation', 'gtd-animation-enums.h'),
+-)
+-
+-enum_types = 'gtd-enum-types'
+-
+-sources += gnome.mkenums(
+- enum_types,
+- sources: enum_headers,
+- c_template: enum_types + '.c.template',
+- h_template: enum_types + '.h.template'
+-)
+-
+-
+ ################
+ # Header files #
+ ################
+diff --git a/src/plugins/meson.build b/src/plugins/meson.build
+index 3d7ac4e4..2a13aff5 100644
+--- a/src/plugins/meson.build
++++ b/src/plugins/meson.build
+@@ -3,7 +3,8 @@ plugins_incs = [
+ include_directories('..'),
+ ]
+
+-plugins_sources = []
++# Ensure enum types header is generated before building plugins
++plugins_sources = [ gtd_enum_types[1] ]
+ plugins_deps = [ endeavour_deps ]
+ plugins_ldflags = []
+ plugins_libs = []
+--
+2.35.1
+
diff --git a/app-office/endeavour/metadata.xml b/app-office/endeavour/metadata.xml
new file mode 100644
index 000000000000..7b343b06be8a
--- /dev/null
+++ b/app-office/endeavour/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>