summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2017-12-20 11:26:04 +0100
committerMarek Szuba <marecki@gentoo.org>2017-12-20 11:36:29 +0100
commit6052378094ebf81f0525ef2e9f4396ef95edb7cb (patch)
tree774d9f9081a1a81a9bc21b93eeab57fd4ef739a6 /app-office/impressive/impressive-0.11.2.ebuild
parentmedia-video/ffmpeg: bump to 3.4.1 (diff)
downloadgentoo-6052378094ebf81f0525ef2e9f4396ef95edb7cb.tar.gz
gentoo-6052378094ebf81f0525ef2e9f4396ef95edb7cb.tar.bz2
gentoo-6052378094ebf81f0525ef2e9f4396ef95edb7cb.zip
app-office/impressive: bump to version 0.11.2 and EAPI 6
app-text/mupdf is now a hard dependency because according to the upstream maintainer, viewing PDF files will simply not work without it. It has also taken over most of the jobs previously handled by app-text/pdftk, which is now an optional enhancement rather than a dependency - it is masked in recent profiles all it is used for when mupdf is present is extraction of PDF page titles. Closes: https://bugs.gentoo.org/579078 Suggested-by: Martin Fiedler <martin.fiedler@gmx.net> Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-office/impressive/impressive-0.11.2.ebuild')
-rw-r--r--app-office/impressive/impressive-0.11.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-office/impressive/impressive-0.11.2.ebuild b/app-office/impressive/impressive-0.11.2.ebuild
new file mode 100644
index 000000000000..14227452dabf
--- /dev/null
+++ b/app-office/impressive/impressive-0.11.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+MY_PN="Impressive"
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${PV%b}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-apps/xrandr
+ app-text/mupdf
+ || ( media-fonts/dejavu media-fonts/corefonts )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=(
+ changelog.txt
+ demo.pdf
+)
+HTML_DOCS=(
+ impressive.html
+)
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ default
+ python_foreach_impl python_doscript ${PN}.py
+ doman impressive.1
+}
+
+pkg_postinst() {
+ elog "The experience with ${PN} can be enhanced by folowing packages:"
+ optfeature "starting web or e-mail hyperlinks from PDF documents" x11-misc/xdg-utils
+ optfeature "sound and video playback" media-video/mplayer
+ optfeature "sound and video playback" media-video/mplayer2
+ optfeature "extraction of PDF page titles" app-text/pdftk
+}