summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-21 12:09:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-29 14:03:42 +0100
commitce86df7eb9cdd27b8da28b84541ed0894fac4b53 (patch)
tree3924362d6b5210d43d0502e02ac8f34b776b09c9 /app-office/kmymoney/kmymoney-5.0.7.ebuild
parentkde5.eclass: Switch to cmake.eclass (diff)
downloadgentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.tar.gz
gentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.tar.bz2
gentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.zip
*/*: Switch kde proj packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office/kmymoney/kmymoney-5.0.7.ebuild')
-rw-r--r--app-office/kmymoney/kmymoney-5.0.7.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-office/kmymoney/kmymoney-5.0.7.ebuild b/app-office/kmymoney/kmymoney-5.0.7.ebuild
index dcb9282ee91c..75cc141e722b 100644
--- a/app-office/kmymoney/kmymoney-5.0.7.ebuild
+++ b/app-office/kmymoney/kmymoney-5.0.7.ebuild
@@ -102,17 +102,17 @@ pkg_setup() {
src_configure() {
local mycmakeargs=(
-DUSE_QT_DESIGNER=OFF
- $(cmake-utils_use_find_package activities KF5Activities)
- $(cmake-utils_use_find_package addressbook KF5Akonadi)
- $(cmake-utils_use_find_package addressbook KF5Contacts)
- $(cmake-utils_use_find_package addressbook KF5IdentityManagement)
+ $(cmake_use_find_package activities KF5Activities)
+ $(cmake_use_find_package addressbook KF5Akonadi)
+ $(cmake_use_find_package addressbook KF5Contacts)
+ $(cmake_use_find_package addressbook KF5IdentityManagement)
-DENABLE_LIBICAL=$(usex calendar)
-DENABLE_KBANKING=$(usex hbci)
- $(cmake-utils_use_find_package holidays KF5Holidays)
+ $(cmake_use_find_package holidays KF5Holidays)
-DENABLE_OFXIMPORTER=$(usex ofx)
-DENABLE_WEBENGINE=$(usex !webkit)
-DENABLE_WEBOOB=$(usex weboob)
- $(cmake-utils_use_find_package weboob PythonLibs)
+ $(cmake_use_find_package weboob PythonLibs)
)
ecm_src_configure
}