summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-11-19 20:27:15 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-19 20:34:21 +0100
commit9b78384c0f8409c97abdb26e8930965700574d44 (patch)
tree89bed3f8155f31c61130017aae64e2f504836fa0 /app-office/kraft/files/kraft-0.80_pre20171115-deps.patch
parentapp-editors/mg: stable 20170828 for hppa, bug #638144 (diff)
downloadgentoo-9b78384c0f8409c97abdb26e8930965700574d44.tar.gz
gentoo-9b78384c0f8409c97abdb26e8930965700574d44.tar.bz2
gentoo-9b78384c0f8409c97abdb26e8930965700574d44.zip
app-office/kraft: Add 0.80_pre20171115 kf5-based snapshot
Bug: https://bugs.gentoo.org/635058 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'app-office/kraft/files/kraft-0.80_pre20171115-deps.patch')
-rw-r--r--app-office/kraft/files/kraft-0.80_pre20171115-deps.patch62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-office/kraft/files/kraft-0.80_pre20171115-deps.patch b/app-office/kraft/files/kraft-0.80_pre20171115-deps.patch
new file mode 100644
index 000000000000..cebf558fd355
--- /dev/null
+++ b/app-office/kraft/files/kraft-0.80_pre20171115-deps.patch
@@ -0,0 +1,62 @@
+From 63248f8004e7e0b05fe1716f6ff432b16b382e8f Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Thu, 16 Nov 2017 22:14:05 +0100
+Subject: [PATCH] Sort deps, add implicit, and split PIM from real KF5 libs
+
+Add descriptions to PIM dependencies.
+---
+ CMakeLists.txt | 33 ++++++++++++++++++++++++++-------
+ 1 file changed, 26 insertions(+), 7 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 739daac..9f95ecf 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,21 +25,40 @@ remove_definitions(-DQT_NO_CAST_FROM_ASCII)
+
+ find_package(Qt5 CONFIG REQUIRED
+ Core
+- Network
+- Widgets
++ Gui
+ Sql
++ Widgets
++ Xml
+ )
+
+ find_package(KF5 REQUIRED COMPONENTS
+- Contacts
++ Config
++ ConfigWidgets
++ CoreAddons
+ I18n
++ WidgetsAddons
+ XmlGui
+- OPTIONAL_COMPONENTS
+- Akonadi
+- AkonadiContact
+ )
+
+-if(KF5Akonadi_FOUND)
++find_package(KF5Contacts REQUIRED)
++
++find_package(KF5Akonadi)
++set_package_properties(KF5Akonadi PROPERTIES
++ DESCRIPTION "Library for general Access to Akonadi"
++ URL "https://www.kde.org/"
++ PURPOSE "Optionally used for addressbook integration"
++ TYPE OPTIONAL
++)
++
++find_package(KF5AkonadiContact)
++set_package_properties(KF5AkonadiContact PROPERTIES
++ DESCRIPTION "Library for Accessing Contacts stored in Akonadi"
++ URL "https://www.kde.org/"
++ PURPOSE "Optionally used for addressbook integration"
++ TYPE OPTIONAL
++)
++
++if(KF5Akonadi_FOUND AND KF5AkonadiContact_FOUND)
+ add_definitions(-DHAVE_AKONADI)
+ endif()
+