summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/libalkimia/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/libalkimia/files')
-rw-r--r--app-office/libalkimia/files/libalkimia-4.3.2-doc.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-office/libalkimia/files/libalkimia-4.3.2-doc.patch b/app-office/libalkimia/files/libalkimia-4.3.2-doc.patch
new file mode 100644
index 000000000000..c88b95b65269
--- /dev/null
+++ b/app-office/libalkimia/files/libalkimia-4.3.2-doc.patch
@@ -0,0 +1,34 @@
+diff -ruN libalkimia-4.3.1.orig/libalkimia/CMakeLists.txt libalkimia-4.3.1/libalkimia/CMakeLists.txt
+--- libalkimia-4.3.1.orig/libalkimia/CMakeLists.txt 2011-08-01 12:14:46.000000000 +0200
++++ libalkimia-4.3.1/libalkimia/CMakeLists.txt 2011-08-01 23:04:41.000000000 +0200
+@@ -86,6 +86,8 @@
+ endif(NOT WIN32)
+ ########### documentation ###################
+
++if(BUILD_DOC)
++
+ # check for Doxygen
+ find_package(Doxygen)
+ if(DOXYGEN_FOUND)
+@@ -95,9 +97,20 @@
+
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/libalkimia.doxygen.in ${CMAKE_CURRENT_BINARY_DIR}/libalkimia.doxygen IMMEDIATE)
+
+- add_custom_target(libalkimia_apidoc ${DOXYGEN} ${CMAKE_CURRENT_BINARY_DIR}/libalkimia.doxygen)
++ add_custom_target(libalkimia_apidoc ALL ${DOXYGEN} ${CMAKE_CURRENT_BINARY_DIR}/libalkimia.doxygen)
++else(DOXYGEN_FOUND)
++ MESSAGE(FATAL_ERROR "API documentation requested but doxygen not found")
+ endif(DOXYGEN_FOUND)
+
++ELSE(BUILD_DOC)
++
++ MESSAGE(STATUS "")
++ MESSAGE(STATUS "Documentation will NOT be installed")
++ MESSAGE(STATUS "Because the option -DBUILD_DOC=ON wasn't passed to cmake")
++ MESSAGE(STATUS "")
++
++ENDIF(BUILD_DOC)
++
+ ########### tests ###################
+
+ set( alkvaluetest_SRCS alkvaluetest.cpp )