summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-15 20:52:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-16 00:12:14 +0100
commit6adbb4a43eec0e8807686a7c16e2591f472d082e (patch)
tree394c1bce1e86f4cee232804639a5075e3ba7c14b /app-office/libreoffice/libreoffice-6.1.9999.ebuild
parentapp-office/libreoffice: Drop obsolete glibc-2.24 patch (diff)
downloadgentoo-6adbb4a43eec0e8807686a7c16e2591f472d082e.tar.gz
gentoo-6adbb4a43eec0e8807686a7c16e2591f472d082e.tar.bz2
gentoo-6adbb4a43eec0e8807686a7c16e2591f472d082e.zip
app-office/libreoffice: Add COMMIT hash to BUILD_ID
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office/libreoffice/libreoffice-6.1.9999.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-6.1.9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/app-office/libreoffice/libreoffice-6.1.9999.ebuild b/app-office/libreoffice/libreoffice-6.1.9999.ebuild
index 6e4ffe4f0266..94aaaa087d8a 100644
--- a/app-office/libreoffice/libreoffice-6.1.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-6.1.9999.ebuild
@@ -20,9 +20,8 @@ ADDONS_URI="https://dev-www.libreoffice.org/src/"
BRANDING="${PN}-branding-gentoo-0.8.tar.xz"
# PATCHSET="${P}-patchset-01.tar.xz"
-[[ ${MY_PV} == *9999* ]] && SCM_ECLASS="git-r3"
-inherit autotools bash-completion-r1 check-reqs eapi7-ver flag-o-matic gnome2-utils java-pkg-opt-2 multiprocessing pax-utils python-single-r1 qmake-utils toolchain-funcs xdg-utils ${SCM_ECLASS}
-unset SCM_ECLASS
+[[ ${MY_PV} == *9999* ]] && inherit git-r3
+inherit autotools bash-completion-r1 check-reqs eapi7-ver flag-o-matic gnome2-utils java-pkg-opt-2 multiprocessing pax-utils python-single-r1 qmake-utils toolchain-funcs xdg-utils
DESCRIPTION="A full office productivity suite"
HOMEPAGE="https://www.libreoffice.org"
@@ -294,6 +293,7 @@ src_unpack() {
[[ ${mypv} != ${MY_PV} ]] && branch="${PN}-${mypv/./-}"
git-r3_fetch "${base_uri}/${PN}/core" "refs/heads/${branch}"
git-r3_checkout "${base_uri}/${PN}/core"
+ LOCOREGIT_VERSION=${EGIT_VERSION}
git-r3_fetch "${base_uri}/${PN}/help" "refs/heads/master"
git-r3_checkout "${base_uri}/${PN}/help" "helpcontent2" # doesn't match on help
@@ -365,6 +365,11 @@ src_configure() {
export MOC5="$(qt5_get_bindir)/moc"
fi
+ local gentoo_buildid="Gentoo official package"
+ if [[ -n ${LOCOREGIT_VERSION} ]]; then
+ gentoo_buildid+=" (from git: ${LOCOREGIT_VERSION})"
+ fi
+
# system headers/libs/...: enforce using system packages
# --disable-breakpad: requires not-yet-in-tree dev-utils/breakpad
# --enable-cairo: ensure that cairo is always required
@@ -403,7 +408,7 @@ src_configure() {
--disable-qt5
--disable-report-builder
--with-alloc=system
- --with-build-version="Gentoo official package"
+ --with-build-version="${gentoo_buildid}"
--enable-extension-integration
--with-external-dict-dir="${EPREFIX}/usr/share/myspell"
--with-external-hyph-dir="${EPREFIX}/usr/share/myspell"