summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-11-19 23:40:04 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-11-19 23:41:00 +0100
commite62775916f1ef4bb75b3683dd4af90f2044ada8a (patch)
treeeebbfb8879a7f65d6d978f07471ec63452df66f4 /app-office/libreoffice/libreoffice-9999.ebuild
parentkde-misc/colord-kde: Drop slot 4 (diff)
downloadgentoo-e62775916f1ef4bb75b3683dd4af90f2044ada8a.tar.gz
gentoo-e62775916f1ef4bb75b3683dd4af90f2044ada8a.tar.bz2
gentoo-e62775916f1ef4bb75b3683dd4af90f2044ada8a.zip
app-office/libreoffice: do not call is-flagq in global scope, bug 593424
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-office/libreoffice/libreoffice-9999.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index ebc28aaf3833..d43f7ea7d2c6 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -246,19 +246,18 @@ PATCHES=(
"${FILESDIR}/${PN}-5.3-system-pyuno.patch"
)
-CHECKREQS_MEMORY="512M"
-
-if [[ ${MERGE_TYPE} != binary ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
- CHECKREQS_DISK_BUILD="22G"
-elif [[ ${MERGE_TYPE} != binary ]] ; then
- CHECKREQS_DISK_BUILD="6G"
-fi
-
pkg_pretend() {
use java || \
ewarn "If you plan to use lbase application you should enable java or you will get various crashes."
if [[ ${MERGE_TYPE} != binary ]]; then
+
+ CHECKREQS_MEMORY="512M"
+ if is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ CHECKREQS_DISK_BUILD="22G"
+ else
+ CHECKREQS_DISK_BUILD="6G"
+ fi
check-reqs_pkg_pretend
if ! $(tc-is-clang) && [[ $(gcc-major-version) -lt 4 ]] || {
@@ -286,7 +285,15 @@ pkg_setup() {
python-single-r1_pkg_setup
xdg_environment_reset
- [[ ${MERGE_TYPE} != binary ]] && check-reqs_pkg_setup
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ CHECKREQS_MEMORY="512M"
+ if is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ CHECKREQS_DISK_BUILD="22G"
+ else
+ CHECKREQS_DISK_BUILD="6G"
+ fi
+ check-reqs_pkg_setup
+ fi
}
src_unpack() {