summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/multitalk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/multitalk')
-rw-r--r--app-office/multitalk/Manifest1
-rw-r--r--app-office/multitalk/files/99multitalk1
-rw-r--r--app-office/multitalk/metadata.xml7
-rw-r--r--app-office/multitalk/multitalk-1.4.ebuild51
4 files changed, 60 insertions, 0 deletions
diff --git a/app-office/multitalk/Manifest b/app-office/multitalk/Manifest
new file mode 100644
index 000000000000..518875b0c347
--- /dev/null
+++ b/app-office/multitalk/Manifest
@@ -0,0 +1 @@
+DIST multitalk-1.4.tar.gz 1735886 SHA256 3d473dff9a1e821df42b1c68a501e0020e3714e0737fdd76243245ac6d3d6657 SHA512 47e38766485b2dd9faed97fc596e2d625fe86afa9606b9d6136fd337e96588707e14f7a3db00c01f7fc8adf07a3de63b94b85f1fa08a3f7817c35820f0ac9719 WHIRLPOOL 26ed5935411b5b262b200ea87e2480df1b6f420b78af7b11f1d5bd95958392559a701bc5e869a817487f58d242c46ed66bc995382ee17d33a81ef9dc9c0cba0e
diff --git a/app-office/multitalk/files/99multitalk b/app-office/multitalk/files/99multitalk
new file mode 100644
index 000000000000..35a623260cf9
--- /dev/null
+++ b/app-office/multitalk/files/99multitalk
@@ -0,0 +1 @@
+MULTITALK_DIR="/usr/share/multitalk"
diff --git a/app-office/multitalk/metadata.xml b/app-office/multitalk/metadata.xml
new file mode 100644
index 000000000000..aba833ed90e0
--- /dev/null
+++ b/app-office/multitalk/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-office/multitalk/multitalk-1.4.ebuild b/app-office/multitalk/multitalk-1.4.ebuild
new file mode 100644
index 000000000000..3443befe65b1
--- /dev/null
+++ b/app-office/multitalk/multitalk-1.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs readme.gentoo
+
+DESCRIPTION="A new type of presentation program"
+HOMEPAGE="http://www.srcf.ucam.org/~dmi1000/multitalk/"
+SRC_URI="http://www.srcf.ucam.org/~dmi1000/multitalk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples latex"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-image-1.2.3
+ >=media-libs/sdl-ttf-2.0.6
+ >=media-libs/sdl-gfx-2.0.13"
+
+RDEPEND="${DEPEND}
+ latex? ( virtual/latex-base
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] ) )"
+
+S="${WORKDIR}/${PN}"
+
+DOC_CONTENTS="
+ You will have to source /etc/profile (or logout and back in).
+ See also /usr/share/doc/${PF}/${PN}.pdf."
+
+src_prepare() {
+ sed -i \
+ -e "s:g++:$(tc-getCXX) ${CXXFLAGS}:" \
+ -e "s:-L\${HOME}/lib:${LDFLAGS}:" \
+ Makefile || die "sed for Makefile failed."
+}
+
+src_install() {
+ dodir /usr/bin
+ emake SYSPREFIX="${D}usr" install
+
+ insinto /usr/share/${PN}/examples
+ doins examples/about.{graph,talk}
+
+ doenvd "${FILESDIR}/99multitalk"
+
+ dodoc README docs/Changelog docs/multitalk.pdf
+
+ readme.gentoo_create_doc
+}