summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2019-08-06 16:54:48 +0700
committerAndrey Grozin <grozin@gentoo.org>2019-08-06 16:55:50 +0700
commitc71f6209a32bb2efc37e738d830439c07cbbf81b (patch)
tree2ae42b758fde34545eb238951bd77e66e70f00ee /app-office/texmacs/texmacs-1.99.11.ebuild
parentmedia-libs/tiff: alpha stable wrt bug #690732 (diff)
downloadgentoo-c71f6209a32bb2efc37e738d830439c07cbbf81b.tar.gz
gentoo-c71f6209a32bb2efc37e738d830439c07cbbf81b.tar.bz2
gentoo-c71f6209a32bb2efc37e738d830439c07cbbf81b.zip
app-office/texmacs: bump to 1.99.11
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-office/texmacs/texmacs-1.99.11.ebuild')
-rw-r--r--app-office/texmacs/texmacs-1.99.11.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/app-office/texmacs/texmacs-1.99.11.ebuild b/app-office/texmacs/texmacs-1.99.11.ebuild
new file mode 100644
index 000000000000..ec2993ea4b57
--- /dev/null
+++ b/app-office/texmacs/texmacs-1.99.11.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils xdg-utils gnome2-utils qmake-utils
+
+MY_P=${P/tex/TeX}-src
+
+DESCRIPTION="Wysiwyg text processor with high-quality maths"
+HOMEPAGE="http://www.texmacs.org/"
+SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/tmftp/source/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug jpeg netpbm sqlite svg spell"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ <dev-scheme/guile-1.9[debug?,deprecated]
+ media-libs/freetype
+ x11-apps/xmodmap
+ x11-libs/libXext
+ virtual/latex-base
+ >=dev-qt/qtcore-5.9.1:5
+ >=dev-qt/qtgui-5.9.1:5
+ >=dev-qt/qtwidgets-5.9.1:5
+ >=dev-qt/qtprintsupport-5.9.1:5
+ sqlite? ( dev-db/sqlite )
+ jpeg? ( || ( media-gfx/imagemagick media-gfx/jpeg2ps ) )
+ netpbm? ( media-libs/netpbm )
+ spell? ( app-text/aspell )
+ svg? ( || ( media-gfx/inkscape gnome-base/librsvg:2 ) )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.99.2-desktop.patch
+
+ # remove new/delete declarations, bug 590002
+ "${FILESDIR}"/${PN}-1.99-remove-new-declaration.patch
+
+ "${FILESDIR}"/${PN}-1.99.6-math_util.patch
+
+ # fix build failure on 32-bit systems, bug #652054
+ # "${FILESDIR}"/${PN}-1.99.6-guile-size_t.patch
+ #"${FILESDIR}"/${PN}-1.99.9-guile-remove-deprecated.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SQLITE3=$(usex sqlite 1 0)
+ -DDEBUG_ASSERT=$(usex debug 1 0)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}