summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-15 19:49:17 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-15 19:49:17 +0200
commitc129b3d1bf778ba053d1510c9a54bb80ff2bd83e (patch)
treecb0c920b01716544c3596fa1b2213aaa94580434 /app-office/texstudio
parentdev-util/drone: Remove old (diff)
downloadgentoo-c129b3d1bf778ba053d1510c9a54bb80ff2bd83e.tar.gz
gentoo-c129b3d1bf778ba053d1510c9a54bb80ff2bd83e.tar.bz2
gentoo-c129b3d1bf778ba053d1510c9a54bb80ff2bd83e.zip
app-office/texstudio: Version bump to 2.12.4
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-office/texstudio')
-rw-r--r--app-office/texstudio/Manifest1
-rw-r--r--app-office/texstudio/texstudio-2.12.4.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/app-office/texstudio/Manifest b/app-office/texstudio/Manifest
index 0716e73a136a..14bfc76b7724 100644
--- a/app-office/texstudio/Manifest
+++ b/app-office/texstudio/Manifest
@@ -1,2 +1,3 @@
DIST texstudio-2.11.2.tar.gz 24143941 SHA256 d88ecfef92e38710563294079645fbfa19829ceebd9a109a68f6959c51ae94ad SHA512 774cea12339b19c7d33d034e75386415b89c59de1e149f3973bd0cf789a28c4cb1cdb026a897228303071dc05f985d4798924c6b253e964d6bdced877ab9f1e7 WHIRLPOOL 8b54419db50640abb0fc03ce3b1206c01bc1d245d0a5b605ccc44cfd6e2821651a18a00bfef7622f6c47bf79da23315704b50febe645373feb161f6f68d809a9
DIST texstudio-2.12.2.tar.gz 26311798 SHA256 3ffdaf0a3cb8bb9801e68ecba7641778b94121b4320de8751b79f2d8718cdcb1 SHA512 255b211fe715ffc91706ab20877ffaa4b8e0710d3e6f381e7a6b8eed19bb889d89d0913756839c1f0c427029c0da9713b78bd1e21769ccc46cf976b65c91c6f6 WHIRLPOOL 84b309579c31dfc77b9e0f86cb1c80381e65f295d27222fd54a471e3d3f12acdaaad21587fa788143db27f651617b566937c35a0de9de470e65192522e98b7d3
+DIST texstudio-2.12.4.tar.gz 26401510 SHA256 dc4752bd8a1c5249d87ccda780822aba65c59c607419b4cc0c0a788f953b210d SHA512 6e1d114ae87c854231399004504e460d078b9bf26ceb25c7fc592b79d3234f9880f8c021c3ddb2ef26a883dbddc2b94f98f368c976aa16973d3c1a6823a4150d WHIRLPOOL f547cfe1333eeba3692849c71b1f326eadf0bc9505a4626e9a0328814bc41339d77d812b97198d872e609f57f47d9f89c62023ef7cfd3ab99d2f2a00e7d3fc5c
diff --git a/app-office/texstudio/texstudio-2.12.4.ebuild b/app-office/texstudio/texstudio-2.12.4.ebuild
new file mode 100644
index 000000000000..7ee81ab7acd7
--- /dev/null
+++ b/app-office/texstudio/texstudio-2.12.4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit fdo-mime gnome2-utils prefix qmake-utils
+
+DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
+HOMEPAGE="http://texstudio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/TeXstudio%20${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="video"
+
+COMMON_DEPEND="
+ app-text/hunspell:=
+ app-text/poppler[qt5]
+ >=dev-libs/quazip-0.7.2[qt5]
+ dev-qt/designer:5
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtscript:5
+ dev-qt/qtsingleapplication[qt5,X]
+ dev-qt/qtsvg:5
+ dev-qt/qttest:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ video? ( media-libs/phonon[qt5] )"
+RDEPEND="${COMMON_DEPEND}
+ app-text/ghostscript-gpl
+ app-text/psutils
+ media-libs/netpbm
+ virtual/latex-base"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}${PV}
+
+src_prepare() {
+ default
+ find hunspell quazip utilities/poppler-data qtsingleapplication -delete || die
+
+ if use video; then
+ sed "/^PHONON/s:$:true:g" -i ${PN}.pro || die
+ fi
+
+ sed \
+ -e '/qtsingleapplication.pri/d' \
+ -i ${PN}.pro || die
+
+ cp "${FILESDIR}"/texmakerx_my.pri ${PN}.pri || die
+ eprefixify ${PN}.pri
+
+ # fix build with quazip-0.7.2 - bug 597930
+ sed -i ${PN}.pro -e "s|include/quazip|&5|" || die
+ sed -i ${PN}.pri -i ${PN}.pro -e "s/-lquazip/&5/" || die
+}
+
+src_configure() {
+ eqmake5 USE_SYSTEM_HUNSPELL=1 USE_SYSTEM_QUAZIP=1
+}
+
+src_install() {
+ local i
+ for i in 16x16 22x22 32x32 48x48 64x64 128x128; do
+ newicon -s ${i} utilities/${PN}${i}.png ${PN}.png
+ done
+ emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}