summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-12-12 07:41:11 +0100
committerHans de Graaff <graaff@gentoo.org>2017-12-12 08:00:01 +0100
commitf5ba4bed3beed3d9f10a77586c0c528fb7b40342 (patch)
tree8929db88608a66765d9e4231baab3caeb5af49df /app-office/unoconv/unoconv-0.8.2.ebuild
parentapp-office/unoconv: remove live ebuild again (diff)
downloadgentoo-f5ba4bed3beed3d9f10a77586c0c528fb7b40342.tar.gz
gentoo-f5ba4bed3beed3d9f10a77586c0c528fb7b40342.tar.bz2
gentoo-f5ba4bed3beed3d9f10a77586c0c528fb7b40342.zip
app-office/unoconv: add 0.8.2
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-office/unoconv/unoconv-0.8.2.ebuild')
-rw-r--r--app-office/unoconv/unoconv-0.8.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-office/unoconv/unoconv-0.8.2.ebuild b/app-office/unoconv/unoconv-0.8.2.ebuild
new file mode 100644
index 000000000000..15bab5d0ef54
--- /dev/null
+++ b/app-office/unoconv/unoconv-0.8.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit eutils python-single-r1
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DESCRIPTION="Convert between document formats supported by Libreoffice"
+HOMEPAGE="http://dag.wieers.com/home-made/unoconv/"
+SRC_URI="https://github.com/dagwieers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ !app-text/odt2txt
+ virtual/ooo
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/timeout.patch"
+ eapply_user
+ python_fix_shebang .
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake -j1 doc-install install install-links DESTDIR="${D}" || die
+
+ dodoc ChangeLog CHANGELOG.md README.adoc || die
+}