summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-25 20:17:41 +0100
committerSam James <sam@gentoo.org>2021-09-25 20:17:41 +0100
commit10cfac24ef2dde2d7bc68937f094969b6f9a12f6 (patch)
tree9607499ead85abbbea0a6eef6b18c654fcc46fe0 /app-office
parentmedia-libs/libmtp: add 1.1.19 (diff)
downloadgentoo-10cfac24ef2dde2d7bc68937f094969b6f9a12f6.tar.gz
gentoo-10cfac24ef2dde2d7bc68937f094969b6f9a12f6.tar.bz2
gentoo-10cfac24ef2dde2d7bc68937f094969b6f9a12f6.zip
app-office/texstudio: add 4.0.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texstudio/Manifest1
-rw-r--r--app-office/texstudio/texstudio-4.0.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-office/texstudio/Manifest b/app-office/texstudio/Manifest
index 19a8b984d067..7596919e0c90 100644
--- a/app-office/texstudio/Manifest
+++ b/app-office/texstudio/Manifest
@@ -1,2 +1,3 @@
DIST texstudio-3.1.1.tar.gz 83239128 BLAKE2B 7aeedba9ec5a404d51e8854a67c2e07f4efdc03882ebe83ba4d5e99376dcac5c906b40f093129106cfbec716be6001ae6c1848f323147289a5d252c713cb25a6 SHA512 b8c843693d781052914f43215ee42c7bafd4bffe676aede966bafa08b4b74616b55a60e611878a8f0188c84d364ba27f86425adfd4e640c7d4390b0fdfcee8c7
DIST texstudio-3.1.2.tar.gz 83987451 BLAKE2B 0649a4f2a429d1d7a6134e154c338f623de23c8b05829a169599f6950b59190736a0f4c2a4dc0e57ae2c47a5eb26594639660a8b691adbb768cb013061d5c1d8 SHA512 c8ce74cca6620ba725c4e8ff66564cc4804f3b922877af5c4952a8cd5b43fdf2deb88c1515f457f75a67d7d29ca1d6307779b8304c0b78b37f585c61a12221c4
+DIST texstudio-4.0.0.tar.gz 88426776 BLAKE2B 616ffaf35a4f2c5e5290517b38301c575b91251374ee96dc58560f40115ffd5e4e68830fe927283dcdf0f9c9b38815fe04a86a7e58e2dc7936b2b32e38bd6662 SHA512 9025e0709145ed9c352f9cfd748087b331fd2894c913d7b7707254050ea41d5df74077c8f94cc3fb19c4700d468d55e91895da1ea474759d83af499ef436cdbc
diff --git a/app-office/texstudio/texstudio-4.0.0.ebuild b/app-office/texstudio/texstudio-4.0.0.ebuild
new file mode 100644
index 000000000000..934f3f61c9e4
--- /dev/null
+++ b/app-office/texstudio/texstudio-4.0.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop qmake-utils xdg
+
+MY_PV="${PV/_/}"
+DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
+HOMEPAGE="https://www.texstudio.org https://github.com/texstudio-org/texstudio"
+SRC_URI="https://github.com/texstudio-org/texstudio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="video"
+
+DEPEND="
+ app-text/hunspell:=
+ app-text/poppler:=[qt5]
+ >=dev-libs/quazip-0.7.3-r1:0=
+ dev-qt/designer:5
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtscript:5
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtsvg:5
+ dev-qt/qttest:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ video? ( >=media-libs/phonon-4.11.0 )
+"
+RDEPEND="
+ ${DEPEND}
+ app-text/ghostscript-gpl
+ app-text/psutils
+ media-libs/netpbm
+ virtual/latex-base
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.5-quazip1.patch" # TODO: upstream
+)
+
+src_prepare() {
+ xdg_src_prepare
+
+ if has_version "<dev-libs/quazip-1.0"; then
+ sed -e "/PKGCONFIG/s/quazip1-qt5/quazip/" -i ${PN}.pro || die
+ fi
+ rm -r src/quazip || die
+
+ if use video; then
+ sed "/^PHONON/s:$:true:g" -i ${PN}.pro || die
+ fi
+
+ sed -e "/qtsingleapplication.pri/s/.*/CONFIG += qtsingleapplication/" \
+ -i ${PN}.pro || die
+}
+
+src_configure() {
+ eqmake5 USE_SYSTEM_HUNSPELL=1 USE_SYSTEM_QUAZIP=1
+}
+
+src_install() {
+ local i
+ for i in 16x16 22x22 32x32 48x48 64x64 128x128; do
+ newicon -s ${i} utilities/${PN}${i}.png ${PN}.png
+ done
+
+ emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
+}