summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-11-13 10:34:40 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-13 10:38:47 +0100
commit12776b3b9276b01f3e8e6d3157157177fce8f17c (patch)
tree76e885764332334c6de85e31706be4613b9b4eb6 /app-office
parentx11-drivers/xf86-input-libinput: add ~sparc wrt bug #538828 (diff)
downloadgentoo-12776b3b9276b01f3e8e6d3157157177fce8f17c.tar.gz
gentoo-12776b3b9276b01f3e8e6d3157157177fce8f17c.tar.bz2
gentoo-12776b3b9276b01f3e8e6d3157157177fce8f17c.zip
app-office/abiword: Replace 'nullptr' by 'NULL'
Gentoo-bug: 599618 Package-Manager: portage-2.3.2
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/abiword-3.0.2.ebuild1
-rw-r--r--app-office/abiword/files/abiword-3.0.2-fix-nullptr-c++98.patch34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-office/abiword/abiword-3.0.2.ebuild b/app-office/abiword/abiword-3.0.2.ebuild
index f84d0cda180f..346ca4ab2caf 100644
--- a/app-office/abiword/abiword-3.0.2.ebuild
+++ b/app-office/abiword/abiword-3.0.2.ebuild
@@ -73,6 +73,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.0.1-libwps-0.4.patch
"${FILESDIR}"/${PN}-3.0.1-fixwps.patch
"${FILESDIR}"/${PN}-3.0.2-fix-installing-readme.patch
+ "${FILESDIR}"/${PN}-3.0.2-fix-nullptr-c++98.patch
)
src_prepare() {
diff --git a/app-office/abiword/files/abiword-3.0.2-fix-nullptr-c++98.patch b/app-office/abiword/files/abiword-3.0.2-fix-nullptr-c++98.patch
new file mode 100644
index 000000000000..f09319693fe4
--- /dev/null
+++ b/app-office/abiword/files/abiword-3.0.2-fix-nullptr-c++98.patch
@@ -0,0 +1,34 @@
+Replace 'nullptr' by NULL in order to allow compiling in C++98 mode.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=599618
+
+--- a/src/af/gr/gtk/gr_UnixCairoGraphics.cpp
++++ b/src/af/gr/gtk/gr_UnixCairoGraphics.cpp
+@@ -180,7 +180,7 @@
+ if (m_styleBg) {
+ g_object_unref(m_styleBg);
+ }
+- m_styleBg = XAP_GtkStyle_get_style(nullptr, "GtkButton"); // "button"
++ m_styleBg = XAP_GtkStyle_get_style(NULL, "GtkButton"); // "button"
+ // guess colours
+ // WHITE
+ GdkRGBA rgba2;
+@@ -627,7 +627,7 @@
+ _setProps();
+ cairo_save (m_cr);
+
+- GtkStyleContext *context = nullptr;
++ GtkStyleContext *context = NULL;
+ switch(c) {
+ case GR_Graphics::CLR3D_Background:
+ context = m_styleBg;
+--- a/src/wp/ap/xp/ap_Dialog_Spell.cpp
++++ b/src/wp/ap/xp/ap_Dialog_Spell.cpp
+@@ -251,7 +251,7 @@
+ UT_return_val_if_fail (m_Suggestions, false);
+
+ // get suggestions from spelling engine
+- const UT_GenericVector<UT_UCSChar*> *cpvEngineSuggestions = nullptr;
++ const UT_GenericVector<UT_UCSChar*> *cpvEngineSuggestions = NULL;
+
+ if (checker->checkWord(m_pWord, m_iWordLength) == SpellChecker::LOOKUP_FAILED)
+ {