summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-04-03 13:59:13 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-04-03 13:59:13 +0300
commit160f42294d17b6c7ac5a0f78cd23eb61d906630b (patch)
tree74c364b0cf6d9b2239e43421777f82bf201e58ae /app-office
parentsys-apps/man-pages: Drop old (diff)
downloadgentoo-160f42294d17b6c7ac5a0f78cd23eb61d906630b.tar.gz
gentoo-160f42294d17b6c7ac5a0f78cd23eb61d906630b.tar.bz2
gentoo-160f42294d17b6c7ac5a0f78cd23eb61d906630b.zip
app-office/texmaker: Version bump (v5.0.4)
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texmaker/Manifest1
-rw-r--r--app-office/texmaker/texmaker-5.0.4.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/app-office/texmaker/Manifest b/app-office/texmaker/Manifest
index 5990a6bedacc..f45528d129e1 100644
--- a/app-office/texmaker/Manifest
+++ b/app-office/texmaker/Manifest
@@ -1 +1,2 @@
DIST texmaker-5.0.3.tar.bz2 15783226 BLAKE2B e023b79a49629f70da234c2194230891da755ce18d0a81405f25d08825f13259f84cb5e7960ec3c2d182179e1695ba6f5b7145a2bd03e0cd0b95723ea88cd456 SHA512 fed09b1ac628f4a8cab24257f2ca35093f20a82d1a3b8c38d12878ff94f0933b7449e5ba651831612b62417426396327ea8ba64e830fe0537757abe65bcd5284
+DIST texmaker-5.0.4.tar.bz2 15812468 BLAKE2B ad252827c7db90ad20de5ca59958124714b7abe660998ef21b983a7888831aaa12fedc018a764ad8898780b18ca97b44145afe548817a867f74b407f0a2c9399 SHA512 34ff5773358c2fffbc9e7e61028cd74eef231152e3483531b66cb0d907dd8f70a4e8b6d6ea09b0b11387b592f6d1676ba8a1e737b26c86a45b16882e53edff1f
diff --git a/app-office/texmaker/texmaker-5.0.4.ebuild b/app-office/texmaker/texmaker-5.0.4.ebuild
new file mode 100644
index 000000000000..e2a77a2cb542
--- /dev/null
+++ b/app-office/texmaker/texmaker-5.0.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils readme.gentoo-r1
+
+DESCRIPTION="A nice LaTeX-IDE"
+HOMEPAGE="https://xm1math.net/texmaker/"
+SRC_URI="https://xm1math.net/texmaker/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ app-text/hunspell:=
+ app-text/poppler[qt5]
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtlockedfile
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtscript:5
+ dev-qt/qtsingleapplication[X,qt5(+)]
+ dev-qt/qtwebengine:5[widgets]
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+"
+RDEPEND="${DEPEND}
+ app-text/ghostscript-gpl
+ app-text/psutils
+ media-libs/netpbm
+ virtual/latex-base
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.0-unbundle-hunspell-singleapp.patch"
+)
+
+DOCS=( utilities/AUTHORS utilities/CHANGELOG.txt )
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ find singleapp hunspell -delete || die
+
+ cat >> ${PN}.pro <<- EOF
+ exists(texmakerx_my.pri):include(texmakerx_my.pri)
+ EOF
+
+ cp "${FILESDIR}"/texmakerx_my.pri . || die
+
+ sed \
+ -e '/^#include/s:hunspell/::g' \
+ -e '/^#include/s:singleapp/::g' \
+ -i *.cpp *.h || die
+
+ DOC_CONTENTS="A user manual with many screenshots is available at:
+ ${EPREFIX}/usr/share/${PN}/usermanual_en.html"
+}
+
+src_configure() {
+ local myeqmakeargs=(
+ ${PN}.pro
+ PREFIX="${EPREFIX}/usr"
+ DESKTOPDIR="${EPREFIX}/usr/share/applications"
+ ICONDIR="${EPREFIX}/usr/share/pixmaps"
+ )
+ eqmake5 ${myeqmakeargs[@]}
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+ readme.gentoo_create_doc
+}