summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-01-06 19:36:04 +0100
committerHans de Graaff <graaff@gentoo.org>2020-01-06 19:36:04 +0100
commit2789c6ac3d4435a63b00312a6cce8c5352b9f12a (patch)
treede4f3a2719a49fa33402eed288b4d33ca7e06723 /app-office
parentwww-client/firefox: workaround compilers that do not exten lifetime (diff)
downloadgentoo-2789c6ac3d4435a63b00312a6cce8c5352b9f12a.tar.gz
gentoo-2789c6ac3d4435a63b00312a6cce8c5352b9f12a.tar.bz2
gentoo-2789c6ac3d4435a63b00312a6cce8c5352b9f12a.zip
app-office/unoconv: add 0.9.0
Closes: https://bugs.gentoo.org/704872 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/unoconv/Manifest1
-rw-r--r--app-office/unoconv/unoconv-0.9.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-office/unoconv/Manifest b/app-office/unoconv/Manifest
index 3eeda75840c3..5d32b34d56ee 100644
--- a/app-office/unoconv/Manifest
+++ b/app-office/unoconv/Manifest
@@ -1,2 +1,3 @@
DIST unoconv-0.8.2.tar.gz 104072 BLAKE2B 1ac16159f939a06cc75f3ff23f5aa7f1c4d49a41d4cce5e9c5866714ef1b3b969f94c074d36fff19d6af22375d5598033fb69761a09d3e60b81d794841c0e0d8 SHA512 cd6a4d06559895c0aebb5fda51ca86928474dd0ca0aa908e81762643186c29cf8436c889eedbb18bc74ed6016414d1aa831cd034614244d5aae677a6b4cdd4c9
+DIST unoconv-0.9.0.tar.gz 108493 BLAKE2B 36761f5cabd8cf0186ffa74202d8a9e0388ab9dc1a135b8e6b2275ed380de79da85d4955bca446810f4f71dff61bd38d7b131a91930729cbabfb10d656ba3891 SHA512 37d63ada32675fd0ebd089a74db453fdb7332a24e62cbf3e060d6d15cc503c76ede9ccc5e09467f4a38833a8358c09fde23cc8780a77c343268f20e0c37f2469
DIST unoconv-0.9.tar.gz 108547 BLAKE2B 6620a7adb32c25182fbb5d0b141ec15d461ee7a73d8644e92337fd7748607d0d33a5978add4c72abf2b35f769f8bbfa35d411f77c4750606e22d6cbc7d7b3454 SHA512 1d6448154ec41776ed4d2ffd87b1caa15e231676a1161072676b1f5a466ea6dbae904de3eafb9ab2718fe4ed0ab7a2c9a91b1d19d79ea382c1e7576ea21e7f04
diff --git a/app-office/unoconv/unoconv-0.9.0.ebuild b/app-office/unoconv/unoconv-0.9.0.ebuild
new file mode 100644
index 000000000000..53aed7fea67a
--- /dev/null
+++ b/app-office/unoconv/unoconv-0.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-single-r1
+
+DESCRIPTION="Convert between document formats supported by LibreOffice"
+HOMEPAGE="http://dag.wiee.rs/home-made/unoconv/"
+SRC_URI="https://github.com/dagwieers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-text/odt2txt
+ virtual/ooo
+"
+
+PATCHES=( "${FILESDIR}/timeout.patch" )
+
+src_prepare() {
+ default
+ python_fix_shebang .
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake -j1 doc-install install install-links DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog CHANGELOG.md README.adoc
+}