summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-14 16:43:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-14 18:13:07 +0200
commit489cdf92cbff00d5f9946533a5928b15e81f17b0 (patch)
tree3e689795974d65f4d2e4e7980d9b7c16b19df04b /app-office
parentdev-lang/go: stabilize 1.17.1 (diff)
downloadgentoo-489cdf92cbff00d5f9946533a5928b15e81f17b0.tar.gz
gentoo-489cdf92cbff00d5f9946533a5928b15e81f17b0.tar.bz2
gentoo-489cdf92cbff00d5f9946533a5928b15e81f17b0.zip
app-office/kexi: Fix build with modern CMake
Closes: https://bugs.gentoo.org/812392 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kexi/files/kexi-3.2.0-fix-find-marble.patch80
-rw-r--r--app-office/kexi/kexi-3.2.0-r1.ebuild3
2 files changed, 82 insertions, 1 deletions
diff --git a/app-office/kexi/files/kexi-3.2.0-fix-find-marble.patch b/app-office/kexi/files/kexi-3.2.0-fix-find-marble.patch
new file mode 100644
index 000000000000..74716a2c37f3
--- /dev/null
+++ b/app-office/kexi/files/kexi-3.2.0-fix-find-marble.patch
@@ -0,0 +1,80 @@
+From 3280c5ec9940f329dc75b2b8d9a52285b20209f0 Mon Sep 17 00:00:00 2001
+From: Johannes Zarl-Zierl <johannes@zarl-zierl.at>
+Date: Wed, 5 May 2021 00:09:49 +0200
+Subject: [PATCH] Use plain Marble package instead of KexiMarble
+
+Marble has shipped with a MarbleConfig.cmake file since ~2016. Kexi
+already depends on KF5 versions that are much newer than that.
+
+* asturm 2021-09-14: Backported to 3.2.0.
+ - s/KEXI/Kexi/ in set_package_properties(Marble ...) to fix patch context
+ - partially merging d09be29f56b94d6a522fa30a5b661926baca973c (drop MARBLE_MIN_VERSION)
+
+---
+ CMakeLists.txt | 8 +-
+ src/plugins/forms/widgets/CMakeLists.txt | 2 +-
+ .../forms/widgets/mapbrowser/CMakeLists.txt | 3 +-
+ 3 files changed, 5 insertions(+), 8 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 97c58fa10..548b2708f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -196,17 +196,14 @@ endif()
+ ##
+ ## Test for marble
+ ##
+-set(MARBLE_MIN_VERSION "0.19.2")
+-find_package(KexiMarble ${MARBLE_MIN_VERSION})
+-set_package_properties(KexiMarble PROPERTIES
++find_package(Marble CONFIG)
++set_package_properties(Marble PROPERTIES
+ DESCRIPTION "KDE World Globe Widget library"
+ URL "https://marble.kde.org"
+ TYPE RECOMMENDED
+ PURPOSE "Required by Kexi form map widget"
+ )
+-if(NOT MARBLE_FOUND)
+- set(MARBLE_INCLUDE_DIR "")
+-else()
++if(Marble_FOUND)
+ set(HAVE_MARBLE TRUE)
+ endif()
+ set_package_properties(GLIB2 PROPERTIES TYPE RECOMMENDED PURPOSE "${_REQUIRED_BY_MDB}")
+diff --git a/src/plugins/forms/widgets/CMakeLists.txt b/src/plugins/forms/widgets/CMakeLists.txt
+index 107d578a8..109341fe0 100644
+--- a/src/plugins/forms/widgets/CMakeLists.txt
++++ b/src/plugins/forms/widgets/CMakeLists.txt
+@@ -11,7 +11,7 @@ endmacro()
+ # the main widgets plugin
+ add_subdirectory(main)
+
+-if(MARBLE_FOUND)
++if(Marble_FOUND)
+ #TODO add_subdirectory(mapbrowser)
+ endif()
+
+diff --git a/src/plugins/forms/widgets/mapbrowser/CMakeLists.txt b/src/plugins/forms/widgets/mapbrowser/CMakeLists.txt
+--- a/src/plugins/forms/widgets/mapbrowser/CMakeLists.txt
++++ b/src/plugins/forms/widgets/mapbrowser/CMakeLists.txt
+@@ -1,7 +1,6 @@
+ include_directories(
+ ${CMAKE_SOURCE_DIR}/src/formeditor
+ ${CMAKE_SOURCE_DIR}/src/core
+- ${MARBLE_INCLUDE_DIR}
+ )
+
+ set(kexiforms_mapwidgetplugin_SRCS
+@@ -20,8 +19,8 @@ target_link_libraries(kexiforms_mapwidgetplugin
+ kexiextendedwidgets
+ kexiformutils
+ kexidataviewcommon
+- ${MARBLE_LIBRARIES}
+
++ Marble
+ Qt5::Xml
+ )
+
+--
+GitLab
+
diff --git a/app-office/kexi/kexi-3.2.0-r1.ebuild b/app-office/kexi/kexi-3.2.0-r1.ebuild
index 73ce61cd4464..89fe7316eccd 100644
--- a/app-office/kexi/kexi-3.2.0-r1.ebuild
+++ b/app-office/kexi/kexi-3.2.0-r1.ebuild
@@ -68,6 +68,7 @@ PATCHES=(
"${FILESDIR}"/${P}-missing-header.patch
"${FILESDIR}"/${P}-postgresql-9.12.patch
"${FILESDIR}"/${P}-glib-2.68.patch # bug 784974
+ "${FILESDIR}"/${P}-fix-find-marble.patch # bug 812392
)
src_prepare() {
@@ -84,7 +85,7 @@ src_configure() {
-DKEXI_MIGRATEMANAGER_DEBUG=$(usex debug)
-DKEXI_AUTORISE_TABBED_TOOLBAR=$(usex experimental)
-DKEXI_SCRIPTS_SUPPORT=$(usex experimental)
- $(cmake_use_find_package marble KexiMarble)
+ $(cmake_use_find_package marble Marble)
$(cmake_use_find_package mdb GLIB2)
$(cmake_use_find_package mysql MySQL)
$(cmake_use_find_package postgres PostgreSQL)