summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-11 03:03:17 +0000
committerSam James <sam@gentoo.org>2021-02-11 03:03:27 +0000
commit4f442daa2d5eb4c98007640358a7127a0b83403b (patch)
tree6fca70aa4f616580d87ec197c3e48303b6785e84 /app-office
parentapp-office/mdbtools: drop obsolete sourceforge remote-id (diff)
downloadgentoo-4f442daa2d5eb4c98007640358a7127a0b83403b.tar.gz
gentoo-4f442daa2d5eb4c98007640358a7127a0b83403b.tar.bz2
gentoo-4f442daa2d5eb4c98007640358a7127a0b83403b.zip
app-office/mdbtools: bump to 0.9.1
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/mdbtools/Manifest1
-rw-r--r--app-office/mdbtools/mdbtools-0.9.1.ebuild53
-rw-r--r--app-office/mdbtools/metadata.xml3
3 files changed, 57 insertions, 0 deletions
diff --git a/app-office/mdbtools/Manifest b/app-office/mdbtools/Manifest
index e214dcc490b5..d732992432c5 100644
--- a/app-office/mdbtools/Manifest
+++ b/app-office/mdbtools/Manifest
@@ -1 +1,2 @@
DIST mdbtools-0.7.1.tar.gz 277257 BLAKE2B 3740c543b1ea2e898a96dc1a560fd83cf079d37f5d02805891c5902b75a417c9efbf421346902766017113d447b088656afbfd0297b26655aa07fce973adc216 SHA512 bbad415c59a3f54c11bcd04971220b1370046c5dfd7300d1f23e597615a1df6af850c6f767e78033676d486d87a11c72dfdb141abbee8378337c3fda9a450b75
+DIST mdbtools-0.9.1.tar.gz 158762 BLAKE2B a730c1ea4efceebb494fc69eac5b94ab23088e0c496684fe027b005492168b6639ec3ebc950e09f643e4a1b50017150caee639255e5e1deb5f9a46c0969077ff SHA512 d8383c20c062a759386e80927337f8ed526914fb53095480dfe791d80fe4cc3e19e83627ca9d34986968b282b16b4c43a6302f76c55d3c2545b6e7b625d47966
diff --git a/app-office/mdbtools/mdbtools-0.9.1.ebuild b/app-office/mdbtools/mdbtools-0.9.1.ebuild
new file mode 100644
index 000000000000..ee7607cd0071
--- /dev/null
+++ b/app-office/mdbtools/mdbtools-0.9.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Set of libraries and utilities for reading Microsoft Access database (MDB) files"
+HOMEPAGE="https://github.com/mdbtools/mdbtools"
+SRC_URI="https://github.com/brianb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="glib odbc"
+
+BDEPEND="
+ app-text/txt2man
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+"
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ odbc? ( >=dev-db/unixODBC-2.0 )
+ glib? ( dev-libs/glib:2 )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS HACKING NEWS README TODO )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable glib)
+ $(use odbc && echo "--with-unixodbc=${EPREFIX}/usr")
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/app-office/mdbtools/metadata.xml b/app-office/mdbtools/metadata.xml
index 26b6d5f18c9a..7ed01d875ad7 100644
--- a/app-office/mdbtools/metadata.xml
+++ b/app-office/mdbtools/metadata.xml
@@ -2,6 +2,9 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
+ <use>
+ <flag name="glib">Use functions provided by <pkg>dev-libs/glib</pkg>, not built-in</flag>
+ </use>
<upstream>
<remote-id type="github">brianb/mdbtools</remote-id>
</upstream>