summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-03-16 13:15:27 +0100
committerPacho Ramos <pacho@gentoo.org>2023-03-16 13:17:32 +0100
commit57087931a816412095b42926445b6f53563098b6 (patch)
tree3e8d2686c902f004224d7f1562d941f9eba9f9b1 /app-office
parentx11-themes/fedora-backgrounds: add github upstream metadata (diff)
downloadgentoo-57087931a816412095b42926445b6f53563098b6.tar.gz
gentoo-57087931a816412095b42926445b6f53563098b6.tar.bz2
gentoo-57087931a816412095b42926445b6f53563098b6.zip
app-office/onlyoffice-bin: new package, add 7.3.3
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/onlyoffice-bin/Manifest1
-rw-r--r--app-office/onlyoffice-bin/metadata.xml15
-rw-r--r--app-office/onlyoffice-bin/onlyoffice-bin-7.3.3.ebuild78
3 files changed, 94 insertions, 0 deletions
diff --git a/app-office/onlyoffice-bin/Manifest b/app-office/onlyoffice-bin/Manifest
new file mode 100644
index 000000000000..2249d5d3a31b
--- /dev/null
+++ b/app-office/onlyoffice-bin/Manifest
@@ -0,0 +1 @@
+DIST onlyoffice-bin-7.3.3_amd64.deb 194296022 BLAKE2B 3f687cd4cfffb742ea078d08b575f3893765f4a82003a52e8645917e3e5f164ed7d547458ee58621dc3cb021bf5bbcc7fa9e88ae5130afac9662c186b256ff1f SHA512 fd3e9a48e488ef8fb8be01f3b1bfeeb87fe1a25d2a81e1716146557cfdf8a3822d36f5a66f43c6cb596d8e072bc1d3407f8320b092d9a1f0e9a54bb9f7920fa8
diff --git a/app-office/onlyoffice-bin/metadata.xml b/app-office/onlyoffice-bin/metadata.xml
new file mode 100644
index 000000000000..d3cc03317573
--- /dev/null
+++ b/app-office/onlyoffice-bin/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>parona@protonmail.com</email>
+ <name>Alfred Wingate</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>pacho@gentoo.org</email>
+ <name>Pacho Ramos</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ONLYOFFICE/DesktopEditors</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-office/onlyoffice-bin/onlyoffice-bin-7.3.3.ebuild b/app-office/onlyoffice-bin/onlyoffice-bin-7.3.3.ebuild
new file mode 100644
index 000000000000..e88bb3d1c410
--- /dev/null
+++ b/app-office/onlyoffice-bin/onlyoffice-bin-7.3.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker xdg
+
+MY_P="ONLYOFFICE-DesktopEditors-"${PV}""
+
+DESCRIPTION="Onlyoffice is an office productivity suite (binary version)"
+HOMEPAGE="https://www.onlyoffice.com/"
+SRC_URI="
+ amd64? (
+ https://github.com/ONLYOFFICE/DesktopEditors/releases/download/v"${PV}"/onlyoffice-desktopeditors_amd64.deb
+ -> "${P}"_amd64.deb
+ )
+"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror strip test"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ dev-libs/wayland
+ dev-qt/qtgui:5[eglfs]
+ dev-qt/qtdeclarative:5
+ dev-qt/qtwayland:5
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/gst-plugins-base:1.0
+ media-libs/gstreamer:1.0
+ media-libs/harfbuzz
+ media-libs/libglvnd
+ media-libs/libpulse
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ x11-libs/pango
+"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="*"
+
+src_install() {
+ domenu usr/share/applications/onlyoffice-desktopeditors.desktop
+ for size in {16,24,32,48,64,128,256}; do
+ newicon -s "${size}" opt/onlyoffice/desktopeditors/asc-de-"${size}".png onlyoffice-desktopeditors.png
+ done
+
+ dobin usr/bin/desktopeditors usr/bin/onlyoffice-desktopeditors
+ doins -r opt
+ fperms +x /opt/onlyoffice/desktopeditors/{DesktopEditors,editors_helper,converter/x2t}
+}