summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Head <chead@chead.ca>2019-11-16 17:48:21 -0800
committerJoonas Niilola <juippis@gentoo.org>2019-11-18 08:14:15 +0200
commit956426a6665c78e317ecef10e90242c7b9644049 (patch)
treeaf414eb886747ff919a3b829df93c1e04ae733cf /app-office
parentapp-office/taskcoach: add longdescription (diff)
downloadgentoo-956426a6665c78e317ecef10e90242c7b9644049.tar.gz
gentoo-956426a6665c78e317ecef10e90242c7b9644049.tar.bz2
gentoo-956426a6665c78e317ecef10e90242c7b9644049.zip
app-office/taskcoach: version bump to 1.4.6
Changes in the new ebuild: * Version bump from 1.4.3 to 1.4.6 * EAPI bump to 7 * versionator.eclass inherit removed (it was not used) * eutils.class inherit replaced with desktop.eclass and PATCHES array * HOMEPAGE changed to HTTPS * LICENSE fixed (COPYRIGHT.txt says GPL 3 or later) * IUSE=libnotify removed (this was not announced in the changelog but the code appears to have been removed) * fix-desktop-file.patch no longer used (patching that file was pointless because the shipped desktop file was ignored in favour of make_desktop_entry anyway) Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Christopher Head <chead@chead.ca> Closes: https://bugs.gentoo.org/677974 Closes: https://github.com/gentoo/gentoo/pull/13679 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/taskcoach/Manifest1
-rw-r--r--app-office/taskcoach/taskcoach-1.4.6.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-office/taskcoach/Manifest b/app-office/taskcoach/Manifest
index 3e346b0449eb..c31fce38278b 100644
--- a/app-office/taskcoach/Manifest
+++ b/app-office/taskcoach/Manifest
@@ -1 +1,2 @@
DIST TaskCoach-1.4.3.tar.gz 2927984 BLAKE2B 998a53fa53624bce8497423e68924962e2cec705b87cfab192a6c5869a915f0de9d5c4394a190d07a50220258e7165b6aaee18449b9b9643a37dd9d9838a6679 SHA512 ae449ae66d29ec884de680179853d5e39814a4e7b10d8e5ca2066f1c85fda328470852a10600e74ade1e4a52c5cdc8f749eceaf4f861f8852c2f47d654e9fc88
+DIST TaskCoach-1.4.6.tar.gz 2927090 BLAKE2B 24f7b2f293d34d8ef0084c7065fdf5de6b01f437c971ad0d504125793ec71581ccedbd6db0701653db409ce04fb99b55f995037510daa58f10e2b15b439dc64b SHA512 f393f9e7d8422e1453a1bd711d08ba6bdcccd5634095262475538dfbd1fb7a943798b6ff197e38367cf8e6162e25fef50178458f73b76f483495d61545bec8fe
diff --git a/app-office/taskcoach/taskcoach-1.4.6.ebuild b/app-office/taskcoach/taskcoach-1.4.6.ebuild
new file mode 100644
index 000000000000..8bacc4b22d5f
--- /dev/null
+++ b/app-office/taskcoach/taskcoach-1.4.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop distutils-r1
+
+MY_PN="TaskCoach"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple personal tasks and todo lists manager"
+HOMEPAGE="https://www.taskcoach.org https://pypi.org/project/TaskCoach/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-3+"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Task Coach can also optionally use igraph to draw task dependency graphs
+# since 1.4.4, but that is not packaged in Gentoo at this time.
+
+DEPEND="
+ dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-10.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${DEPEND}
+ x11-libs/libXScrnSaver
+"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CHANGES.txt README.txt )
+PATCHES=( "${FILESDIR}/${PN}-1.4.3-version-check.patch" )
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doicon "icons.in/${PN}.png"
+ make_desktop_entry ${PN}.py "Task Coach" ${PN} Office
+}