summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-03-26 14:55:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-03-26 14:55:38 +0200
commit9da1c2adbbef9c70f9a25603dd853fde43677cb1 (patch)
tree55a31fbbf7acd32b185a9664fca19fe75f014aea /app-office
parentcmake.eclass: Set Python3_FIND_UNVERSIONED_NAMES FIRST (diff)
downloadgentoo-9da1c2adbbef9c70f9a25603dd853fde43677cb1.tar.gz
gentoo-9da1c2adbbef9c70f9a25603dd853fde43677cb1.tar.bz2
gentoo-9da1c2adbbef9c70f9a25603dd853fde43677cb1.zip
app-office/libalkimia: Another cmake fix, this time from upstream
Bug: https://bugs.gentoo.org/878397 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libalkimia/files/libalkimia-8.1.0-cmake-webengine.patch27
-rw-r--r--app-office/libalkimia/libalkimia-8.1.1-r1.ebuild (renamed from app-office/libalkimia/libalkimia-8.1.1.ebuild)7
2 files changed, 32 insertions, 2 deletions
diff --git a/app-office/libalkimia/files/libalkimia-8.1.0-cmake-webengine.patch b/app-office/libalkimia/files/libalkimia-8.1.0-cmake-webengine.patch
new file mode 100644
index 000000000000..7d1140ca7509
--- /dev/null
+++ b/app-office/libalkimia/files/libalkimia-8.1.0-cmake-webengine.patch
@@ -0,0 +1,27 @@
+From 09a11cee26af4ca55e5839dd44e32400147dc119 Mon Sep 17 00:00:00 2001
+From: Alexander Lohnau <alexander.lohnau@gmx.de>
+Date: Sun, 11 Sep 2022 11:55:49 +0200
+Subject: [PATCH] Fix finding of WebEngineWidgets
+
+---
+ src/LibAlkimiaConfig.cmake.in | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/LibAlkimiaConfig.cmake.in b/src/LibAlkimiaConfig.cmake.in
+index 5c2dfc3..1ad866e 100644
+--- a/src/LibAlkimiaConfig.cmake.in
++++ b/src/LibAlkimiaConfig.cmake.in
+@@ -9,7 +9,9 @@ if("@BUILD_QT4@" STREQUAL "ON" OR "@BUILD_QT4@" STREQUAL "1")
+ else()
+ find_dependency(Qt5Core)
+ find_dependency(Qt5DBus)
+- if (@QT_BROWSER_LIB@)
++ if (@BUILD_WITH_WEBENGINE@)
++ find_dependency(Qt@QT_MAJOR_VERSION@WebEngineWidgets 5.15.0)
++ elseif (@QT_BROWSER_LIB@)
+ find_dependency(@QT_BROWSER_LIB@)
+ endif()
+ if (@QT_NETWORK_LIB@)
+--
+2.40.0
+
diff --git a/app-office/libalkimia/libalkimia-8.1.1.ebuild b/app-office/libalkimia/libalkimia-8.1.1-r1.ebuild
index 0d5b5f054028..0cebd5e68506 100644
--- a/app-office/libalkimia/libalkimia-8.1.1.ebuild
+++ b/app-office/libalkimia/libalkimia-8.1.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -54,7 +54,10 @@ BDEPEND="
doc? ( app-doc/doxygen )
"
-PATCHES=( "${FILESDIR}/${PN}-8.1.0-cmake.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-8.1.0-cmake.patch"
+ "${FILESDIR}/${PN}-8.1.0-cmake-webengine.patch"
+)
src_configure() {
local mycmakeargs=(