summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-05 22:48:20 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-05 22:48:29 +0100
commitba66d6b44e7371c11a5cbfdd314522a6c44114b4 (patch)
treeb9e224ea9eb98ad80620cc917c8cf62800e7a253 /app-office
parentapp-misc/screen: Stabilize 4.8.0-r2 arm64, #769770 (diff)
downloadgentoo-ba66d6b44e7371c11a5cbfdd314522a6c44114b4.tar.gz
gentoo-ba66d6b44e7371c11a5cbfdd314522a6c44114b4.tar.bz2
gentoo-ba66d6b44e7371c11a5cbfdd314522a6c44114b4.zip
app-office/libalkimia: Fix build with IUSE=-webengine
Closes: https://bugs.gentoo.org/774321 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libalkimia/files/libalkimia-8.1.0-missing-header.patch25
-rw-r--r--app-office/libalkimia/libalkimia-8.1.0.ebuild5
2 files changed, 29 insertions, 1 deletions
diff --git a/app-office/libalkimia/files/libalkimia-8.1.0-missing-header.patch b/app-office/libalkimia/files/libalkimia-8.1.0-missing-header.patch
new file mode 100644
index 000000000000..c1f1ff463ee3
--- /dev/null
+++ b/app-office/libalkimia/files/libalkimia-8.1.0-missing-header.patch
@@ -0,0 +1,25 @@
+From 0e398425030bae0cfe7be70ce82d61e674160a97 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Fri, 5 Mar 2021 22:40:40 +0100
+Subject: [PATCH] Add missing QUrl include with -DBUILD_WITH_WEBENGINE=no
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ tools/onlinequoteseditor/mainwindow.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tools/onlinequoteseditor/mainwindow.cpp b/tools/onlinequoteseditor/mainwindow.cpp
+index fad7e85..d5a3026 100644
+--- a/tools/onlinequoteseditor/mainwindow.cpp
++++ b/tools/onlinequoteseditor/mainwindow.cpp
+@@ -28,6 +28,7 @@
+ #include <QComboBox>
+ #include <QDockWidget>
+ #include <QLineEdit>
++#include <QUrl>
+
+ class MainWindow::Private
+ {
+--
+2.30.1
+
diff --git a/app-office/libalkimia/libalkimia-8.1.0.ebuild b/app-office/libalkimia/libalkimia-8.1.0.ebuild
index 97ecb376f53e..aa2e49145433 100644
--- a/app-office/libalkimia/libalkimia-8.1.0.ebuild
+++ b/app-office/libalkimia/libalkimia-8.1.0.ebuild
@@ -54,7 +54,10 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-cmake.patch"
+ "${FILESDIR}/${P}-missing-header.patch" # bug 774321
+)
src_configure() {
local mycmakeargs=(