summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-03-12 16:45:27 -0400
committerMike Gilbert <floppym@gentoo.org>2020-03-12 16:49:19 -0400
commitc9c0ae5419485d7fc93be4a449a49f2fd7335631 (patch)
tree40e775286f60dd40da78e77cabab9f7cd56a0d71 /app-office
parentapp-office/calcurse: remove pointless multilib code (diff)
downloadgentoo-c9c0ae5419485d7fc93be4a449a49f2fd7335631.tar.gz
gentoo-c9c0ae5419485d7fc93be4a449a49f2fd7335631.tar.bz2
gentoo-c9c0ae5419485d7fc93be4a449a49f2fd7335631.zip
app-office/calcurse: wire up python-single-r1
Package-Manager: Portage-2.3.92_p3, Repoman-2.3.20_p118 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/calcurse/calcurse-4.4.0-r1.ebuild (renamed from app-office/calcurse/calcurse-4.4.0.ebuild)17
1 files changed, 15 insertions, 2 deletions
diff --git a/app-office/calcurse/calcurse-4.4.0.ebuild b/app-office/calcurse/calcurse-4.4.0-r1.ebuild
index aed85d935654..4f73bc667627 100644
--- a/app-office/calcurse/calcurse-4.4.0.ebuild
+++ b/app-office/calcurse/calcurse-4.4.0-r1.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+PYTHON_COMPAT=( python3_{6..8} )
-inherit autotools eutils
+inherit autotools eutils python-single-r1
DESCRIPTION="a text-based calendar and scheduling application"
HOMEPAGE="https://calcurse.org/"
@@ -12,9 +13,11 @@ SRC_URI="https://calcurse.org/files/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
- dev-python/httplib2
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/httplib2[${PYTHON_MULTI_USEDEP}]')
sys-libs/ncurses:0="
DEPEND="
@@ -27,7 +30,17 @@ PATCHES=(
# Most tests fail.
RESTRICT="test"
+pkg_setup() {
+ :
+}
+
src_prepare() {
default
eautoreconf
}
+
+src_compile() {
+ default
+ python_setup
+ python_fix_shebang contrib/caldav/calcurse-caldav
+}