summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-03-12 16:45:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-03-12 16:52:47 +0100
commite9d8ae7fb9907b04ad32cd80ad0eec978ac92126 (patch)
treece40d4b5da648dd5e3b1832b89d7dc7c75012951 /app-office
parentapp-office/calligra: Fix build with >=app-text/poppler-22.03.0 (diff)
downloadgentoo-e9d8ae7fb9907b04ad32cd80ad0eec978ac92126.tar.gz
gentoo-e9d8ae7fb9907b04ad32cd80ad0eec978ac92126.tar.bz2
gentoo-e9d8ae7fb9907b04ad32cd80ad0eec978ac92126.zip
app-office/libreoffice: Fix build with >=app-text/poppler-22.03.0
Patch taken from Arch Linux Closes: https://bugs.gentoo.org/834538 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/files/libreoffice-7.2.6.2-poppler-22.03.0.patch33
-rw-r--r--app-office/libreoffice/libreoffice-7.2.6.2.ebuild3
-rw-r--r--app-office/libreoffice/libreoffice-7.3.1.3.ebuild3
3 files changed, 39 insertions, 0 deletions
diff --git a/app-office/libreoffice/files/libreoffice-7.2.6.2-poppler-22.03.0.patch b/app-office/libreoffice/files/libreoffice-7.2.6.2-poppler-22.03.0.patch
new file mode 100644
index 000000000000..be4a39993ddb
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-7.2.6.2-poppler-22.03.0.patch
@@ -0,0 +1,33 @@
+From 001ec0e10616a3a55fa7898bb68c983e94b7ce66 Mon Sep 17 00:00:00 2001
+From: foutrelis <foutrelis@eb2447ed-0c53-47e4-bac8-5bc4a241df78>
+Date: Wed, 2 Mar 2022 12:58:09 +0000
+Subject: [PATCH] upgpkg: libreoffice-fresh 7.3.0-7: poppler 22.03.0 rebuild
+
+diff --git a/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
+index ad6320139..e5f6d9c68 100644
+--- a/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
++++ b/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
+@@ -138,6 +138,15 @@ int main(int argc, char **argv)
+ _setmode( _fileno( g_binary_out ), _O_BINARY );
+ #endif
+
++#if POPPLER_CHECK_VERSION(22, 3, 0)
++ PDFDoc aDoc( std::make_unique<GooString>(pFileName),
++ GooString(pOwnerPasswordStr),
++ GooString(pUserPasswordStr) );
++
++ PDFDoc aErrDoc( std::make_unique<GooString>(pErrFileName),
++ GooString(pOwnerPasswordStr),
++ GooString(pUserPasswordStr) );
++#else
+ PDFDoc aDoc( pFileName,
+ pOwnerPasswordStr,
+ pUserPasswordStr );
+@@ -145,6 +154,7 @@ int main(int argc, char **argv)
+ PDFDoc aErrDoc( pErrFileName,
+ pOwnerPasswordStr,
+ pUserPasswordStr );
++#endif
+
+ // Check various permissions for aDoc.
+ PDFDoc &rDoc = aDoc.isOk()? aDoc: aErrDoc;
diff --git a/app-office/libreoffice/libreoffice-7.2.6.2.ebuild b/app-office/libreoffice/libreoffice-7.2.6.2.ebuild
index e2b8f99a1ca1..e51b271e87c1 100644
--- a/app-office/libreoffice/libreoffice-7.2.6.2.ebuild
+++ b/app-office/libreoffice/libreoffice-7.2.6.2.ebuild
@@ -294,6 +294,9 @@ PATCHES=(
"${FILESDIR}/${PN}-6.1-nomancompress.patch"
"${FILESDIR}/${PN}-7.2.0.4-qt5detect.patch"
+ # TODO upstream
+ "${FILESDIR}/${P}-poppler-22.03.0.patch" # by Archlinux
+
# 7.3 branch
"${FILESDIR}/${PN}-7.2.2.2-makefile-gengal.patch"
)
diff --git a/app-office/libreoffice/libreoffice-7.3.1.3.ebuild b/app-office/libreoffice/libreoffice-7.3.1.3.ebuild
index e4211ec16391..9b774db180ef 100644
--- a/app-office/libreoffice/libreoffice-7.3.1.3.ebuild
+++ b/app-office/libreoffice/libreoffice-7.3.1.3.ebuild
@@ -297,6 +297,9 @@ PATCHES=(
"${FILESDIR}/${PN}-5.3.4.2-kioclient5.patch"
"${FILESDIR}/${PN}-6.1-nomancompress.patch"
"${FILESDIR}/${PN}-7.2.0.4-qt5detect.patch"
+
+ # TODO upstream
+ "${FILESDIR}/${PN}-7.2.6.2-poppler-22.03.0.patch" # by Archlinux
)
S="${WORKDIR}/${PN}-${MY_PV}"