summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Castagnino <casta@xwing.info>2018-07-07 16:29:55 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-11 09:50:06 +0100
commitfca8065a2b1ec753969b261a3a4c53db3ca08414 (patch)
treec398f7f1fa1a7be2f478cc31414ecffda28af60e /app-office
parentapp-misc/selecta: new package (diff)
downloadgentoo-fca8065a2b1ec753969b261a3a4c53db3ca08414.tar.gz
gentoo-fca8065a2b1ec753969b261a3a4c53db3ca08414.tar.bz2
gentoo-fca8065a2b1ec753969b261a3a4c53db3ca08414.zip
app-office/grisbi: version bump
Package-Manager: Portage-2.3.41, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9083
Diffstat (limited to 'app-office')
-rw-r--r--app-office/grisbi/Manifest1
-rw-r--r--app-office/grisbi/grisbi-1.0.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-office/grisbi/Manifest b/app-office/grisbi/Manifest
index 34902de0ba7c..992f32e3428b 100644
--- a/app-office/grisbi/Manifest
+++ b/app-office/grisbi/Manifest
@@ -1 +1,2 @@
DIST grisbi-1.0.2.tar.bz2 6956892 BLAKE2B dde75fbae341fc03226083567ff4731457abc7079ace92956c9e8b35ba4140dba32dc67ebe3b2a4826750229dbcd09da0f2eaf1f18c8783238d3fee274c46be9 SHA512 5988d362db8e94f135af34de1acfd7222ceeca11d229ffca533ca75c75c8054dda121bc45979106ee8f4ed2ac0660ba7836dfd053478fdbe4a2984cb94be3cf8
+DIST grisbi-1.0.4.tar.bz2 6965398 BLAKE2B f53b5cd7f2e4b0cdcf14732ba7e03315ec7d419c7f6ab3a290fd30a9dc9f7c0dde69b473dca3873aeb90b793cd90287c516f2fe4b7a50d71368abc3e12ce16f6 SHA512 9761ed94db563c39cab793ee076b6a729470231e3111d7ce57d188a6f1681cbb715174f67c15741320f295d4efdf0784f6e3d4d4d58267759efbad56561c7064
diff --git a/app-office/grisbi/grisbi-1.0.4.ebuild b/app-office/grisbi/grisbi-1.0.4.ebuild
new file mode 100644
index 000000000000..392f5fbf64ad
--- /dev/null
+++ b/app-office/grisbi/grisbi-1.0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Grisbi is a personal accounting application for Linux"
+HOMEPAGE="http://www.grisbi.org"
+SRC_URI="mirror://sourceforge/grisbi/grisbi%20stable/1.0.x/${P}.tar.bz2"
+IUSE="libressl nls ofx ssl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=dev-libs/glib-2.18.0:2
+ >=x11-libs/gtk+-2.12.0:2
+ x11-misc/xdg-utils
+ ssl? (
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( >=dev-libs/openssl-0.9.5:0= ) )
+ ofx? ( >=dev-libs/libofx-0.7.0 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --with-libxml2 \
+ --without-cunit \
+ --disable-static \
+ $(use_with ssl openssl) \
+ $(use_with ofx) \
+ $(use_enable nls)
+}