summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-11-13 01:15:31 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-11-13 01:15:48 +0100
commitfe6e536c6a5c4ac3c49ca11f475eb065aa1be2f2 (patch)
tree537d58294e936e74f2e3787bbbdbc8f60ea5a78b /app-office
parentmedia-libs/jasper: Remove old version (diff)
downloadgentoo-fe6e536c6a5c4ac3c49ca11f475eb065aa1be2f2.tar.gz
gentoo-fe6e536c6a5c4ac3c49ca11f475eb065aa1be2f2.tar.bz2
gentoo-fe6e536c6a5c4ac3c49ca11f475eb065aa1be2f2.zip
app-office/libreoffice: Force Qt4 moc and qmake, bug 599076
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/libreoffice-5.2.3.3.ebuild8
-rw-r--r--app-office/libreoffice/libreoffice-5.2.9999.ebuild8
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild8
3 files changed, 21 insertions, 3 deletions
diff --git a/app-office/libreoffice/libreoffice-5.2.3.3.ebuild b/app-office/libreoffice/libreoffice-5.2.3.3.ebuild
index 49e408104b58..96fefc749ea1 100644
--- a/app-office/libreoffice/libreoffice-5.2.3.3.ebuild
+++ b/app-office/libreoffice/libreoffice-5.2.3.3.ebuild
@@ -25,7 +25,7 @@ BRANDING="${PN}-branding-gentoo-0.8.tar.xz"
# PATCHSET="${P}-patchset-01.tar.xz"
[[ ${PV} == *9999* ]] && SCM_ECLASS="git-r3"
-inherit multiprocessing autotools bash-completion-r1 check-reqs eutils java-pkg-opt-2 kde4-base pax-utils python-single-r1 multilib toolchain-funcs flag-o-matic versionator xdg-utils ${SCM_ECLASS}
+inherit multiprocessing autotools bash-completion-r1 check-reqs eutils java-pkg-opt-2 kde4-base pax-utils python-single-r1 multilib toolchain-funcs flag-o-matic versionator xdg-utils qmake-utils ${SCM_ECLASS}
unset SCM_ECLASS
DESCRIPTION="A full office productivity suite"
@@ -394,6 +394,12 @@ src_configure() {
java_opts+=" --with-rhino-jar=$(java-pkg_getjar rhino-1.6 js.jar)"
fi
+ if use kde; then
+ # bug 544108, bug 599076
+ export QMAKEQT4="$(qt4_get_bindir)/qmake"
+ export MOCQT4="$(qt4_get_bindir)/moc"
+ fi
+
# system headers/libs/...: enforce using system packages
# --enable-cairo: ensure that cairo is always required
# --enable-graphite: disabling causes build breakages
diff --git a/app-office/libreoffice/libreoffice-5.2.9999.ebuild b/app-office/libreoffice/libreoffice-5.2.9999.ebuild
index 49e408104b58..96fefc749ea1 100644
--- a/app-office/libreoffice/libreoffice-5.2.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-5.2.9999.ebuild
@@ -25,7 +25,7 @@ BRANDING="${PN}-branding-gentoo-0.8.tar.xz"
# PATCHSET="${P}-patchset-01.tar.xz"
[[ ${PV} == *9999* ]] && SCM_ECLASS="git-r3"
-inherit multiprocessing autotools bash-completion-r1 check-reqs eutils java-pkg-opt-2 kde4-base pax-utils python-single-r1 multilib toolchain-funcs flag-o-matic versionator xdg-utils ${SCM_ECLASS}
+inherit multiprocessing autotools bash-completion-r1 check-reqs eutils java-pkg-opt-2 kde4-base pax-utils python-single-r1 multilib toolchain-funcs flag-o-matic versionator xdg-utils qmake-utils ${SCM_ECLASS}
unset SCM_ECLASS
DESCRIPTION="A full office productivity suite"
@@ -394,6 +394,12 @@ src_configure() {
java_opts+=" --with-rhino-jar=$(java-pkg_getjar rhino-1.6 js.jar)"
fi
+ if use kde; then
+ # bug 544108, bug 599076
+ export QMAKEQT4="$(qt4_get_bindir)/qmake"
+ export MOCQT4="$(qt4_get_bindir)/moc"
+ fi
+
# system headers/libs/...: enforce using system packages
# --enable-cairo: ensure that cairo is always required
# --enable-graphite: disabling causes build breakages
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 13dd853c424e..87acbbcd61e0 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -25,7 +25,7 @@ BRANDING="${PN}-branding-gentoo-0.8.tar.xz"
# PATCHSET="${P}-patchset-01.tar.xz"
[[ ${PV} == *9999* ]] && SCM_ECLASS="git-r3"
-inherit multiprocessing autotools bash-completion-r1 check-reqs eutils java-pkg-opt-2 kde4-base pax-utils python-single-r1 multilib toolchain-funcs flag-o-matic versionator xdg-utils ${SCM_ECLASS}
+inherit multiprocessing autotools bash-completion-r1 check-reqs eutils java-pkg-opt-2 kde4-base pax-utils python-single-r1 multilib toolchain-funcs flag-o-matic versionator xdg-utils qmake-utils ${SCM_ECLASS}
unset SCM_ECLASS
DESCRIPTION="A full office productivity suite"
@@ -393,6 +393,12 @@ src_configure() {
java_opts+=" --with-rhino-jar=$(java-pkg_getjar rhino-1.6 js.jar)"
fi
+ if use kde; then
+ # bug 544108, bug 599076
+ export QMAKEQT4="$(qt4_get_bindir)/qmake"
+ export MOCQT4="$(qt4_get_bindir)/moc"
+ fi
+
# system headers/libs/...: enforce using system packages
# --disable-breakpad: requires not-yet-in-tree dev-utils/breakpad
# --enable-cairo: ensure that cairo is always required