summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-01 11:01:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-01 11:06:10 +0100
commit1e510087012cfe1c7dcbc22afd2daf7901c272eb (patch)
treebb6c23e3d2115fdb0669da93a9218523b9f55440 /app-officeext/ooofbtools/ooofbtools-2.56.ebuild
parentsci-astronomy/stellarium: version bump - 0.19.3 (diff)
downloadgentoo-1e510087012cfe1c7dcbc22afd2daf7901c272eb.tar.gz
gentoo-1e510087012cfe1c7dcbc22afd2daf7901c272eb.tar.bz2
gentoo-1e510087012cfe1c7dcbc22afd2daf7901c272eb.zip
app-officeext/ooofbtools: 2.56 version bump
Reported-by: Sergey S. Starikoff <Ikonta@yandex.ru> Closes: https://bugs.gentoo.org/690558 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-officeext/ooofbtools/ooofbtools-2.56.ebuild')
-rw-r--r--app-officeext/ooofbtools/ooofbtools-2.56.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-officeext/ooofbtools/ooofbtools-2.56.ebuild b/app-officeext/ooofbtools/ooofbtools-2.56.ebuild
new file mode 100644
index 000000000000..942835191ddb
--- /dev/null
+++ b/app-officeext/ooofbtools/ooofbtools-2.56.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="OOoFBTools"
+OFFICE_EXTENSIONS=( "${MY_PN}.oxt" )
+inherit office-ext-r1
+
+DESCRIPTION="Open/LibreOffice extension for the FictionBook2 format with validation"
+HOMEPAGE="https://sourceforge.net/projects/fbtools/"
+SRC_URI="mirror://sourceforge/fbtools/files/release/${MY_PN}-${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-arch/zip
+ dev-libs/libxml2
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+OFFICE_EXTENSIONS_LOCATION="${S}"
+
+src_prepare() {
+ default
+
+ # Remove Windows cruft
+ pushd "${WORKDIR}/${MY_PN}.oxt" &>/dev/null || die
+ rm -r win32 || die
+ popd &>/dev/null || die
+}
+
+src_install() {
+ office-ext-r1_src_install
+ dodoc ChangeLog*
+}