summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/coldsync
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/coldsync')
-rw-r--r--app-pda/coldsync/Manifest2
-rw-r--r--app-pda/coldsync/coldsync-2.2.5-r1.ebuild76
-rw-r--r--app-pda/coldsync/coldsync-3.0_pre4.ebuild87
-rw-r--r--app-pda/coldsync/files/coldsync-2.2.5-toolchain.patch25
-rw-r--r--app-pda/coldsync/files/coldsync-3.0_pre4-texinfo-5.patch27
-rw-r--r--app-pda/coldsync/metadata.xml5
6 files changed, 222 insertions, 0 deletions
diff --git a/app-pda/coldsync/Manifest b/app-pda/coldsync/Manifest
new file mode 100644
index 000000000000..9d7d72fe9903
--- /dev/null
+++ b/app-pda/coldsync/Manifest
@@ -0,0 +1,2 @@
+DIST coldsync-2.2.5.tar.gz 663307 SHA256 635575e2175a865827319ad21cbfbac95a42a7256730898ae9e9104b63b4fef6 SHA512 94ca6f3cff2248563c9a179d052f1e31f9482a62bd6988baecdb0fd8d9ed376c7653eba15448a8be1585d0ab0f727597985d459fd063fe70a4b77a9ed9298a7a WHIRLPOOL 85f1fe15299f024b6bc9d86127f146298c805adfe46009f90a2ae171e1f3c217a7708bbd8111095e0102cae4bdf1c508ce0bdfe66bf118813ca14026f1f79fa8
+DIST coldsync-3.0-pre4.tar.gz 657305 SHA256 ca32dbcd1b2d3cbce8ee4e34aafb1183fc09c3ead69d308e76454a9c4c4728c3 SHA512 9f8ad373b2613388dfa47c86a65c05378f66b59ce09e5c984617fbb72525a5f31f90dd09a22258ada469a29278cdd442632747c8d2f924372bfbd6e0ba4bec22 WHIRLPOOL e05cee91e61cdd979efcab168d10834f9b0fb8e19a3a488efa99b910490051857358a3c9c9c548acb62b9fcd96268b7d717549f6a9882c434446729af928ba9f
diff --git a/app-pda/coldsync/coldsync-2.2.5-r1.ebuild b/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
new file mode 100644
index 000000000000..6d5af383f7d4
--- /dev/null
+++ b/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic perl-module toolchain-funcs
+
+DESCRIPTION="A command-line tool to synchronize PalmOS PDAs with Unix workstations"
+HOMEPAGE="http://www.coldsync.org/"
+SRC_URI="http://www.coldsync.org/download/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE="nls perl"
+
+RDEPEND="perl? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-toolchain.patch
+
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_prepare
+ popd
+ fi
+}
+
+src_configure() {
+ tc-export CC CXX
+ append-cflags -fno-strict-aliasing
+
+ # TODO: i18n: msgfmt fails but doesn't || die
+ econf \
+ $(use_with nls i18n) \
+ --without-perl
+
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_compile
+ popd
+ fi
+}
+
+src_install() {
+ emake \
+ PREFIX="${D}"/usr \
+ MANDIR="${D}"/usr/share/man \
+ SYSCONFDIR="${D}"/etc \
+ DATADIR="${D}"/usr/share \
+ INFODIR="${D}"/usr/share/info \
+ INSTALLMAN3DIR="${D}"/usr/share/man/man3 \
+ INSTALLSITEMAN3DIR="${D}"/usr/share/man/man3 \
+ INSTALLVENDORMAN3DIR="${D}"/usr/share/man/man3 \
+ install
+
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_install
+ popd
+ fi
+
+ dodoc AUTHORS ChangeLog FAQ HACKING NEWS README* TODO
+}
diff --git a/app-pda/coldsync/coldsync-3.0_pre4.ebuild b/app-pda/coldsync/coldsync-3.0_pre4.ebuild
new file mode 100644
index 000000000000..aa1d65f6ccb0
--- /dev/null
+++ b/app-pda/coldsync/coldsync-3.0_pre4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic eutils perl-module toolchain-funcs
+
+MY_P=${PN}-${PV/_/-}
+
+DESCRIPTION="A command-line tool to synchronize PalmOS PDAs with Unix workstations"
+HOMEPAGE="http://www.coldsync.org/"
+SRC_URI="http://www.coldsync.org/download/${MY_P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="caps nls perl usb"
+
+RDEPEND="caps? ( sys-libs/libcap )
+ perl? ( dev-lang/perl )
+ usb? ( virtual/libusb:0 )"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-texinfo-5.patch
+
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_prepare
+ popd
+ fi
+}
+
+src_configure() {
+ tc-export CC CXX
+ append-cflags -fno-strict-aliasing
+ # FIXME: Fails to link later because libpconn is underlinked with USE="usb".
+ append-ldflags $(no-as-needed)
+
+ econf \
+ $(use_with nls i18n) \
+ $(use_with caps capabilities) \
+ $(use_with usb libusb) \
+ --without-perl
+
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ emake -j1 #279292
+
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_compile
+ popd
+ fi
+}
+
+src_install() {
+ emake \
+ PREFIX="${D}"/usr \
+ MANDIR="${D}"/usr/share/man \
+ SYSCONFDIR="${D}"/etc \
+ DATADIR="${D}"/usr/share \
+ INFODIR="${D}"/usr/share/info \
+ INSTALLMAN3DIR="${D}"/usr/share/man/man3 \
+ INSTALLSITEMAN3DIR="${D}"/usr/share/man/man3 \
+ INSTALLVENDORMAN3DIR="${D}"/usr/share/man/man3 \
+ EXTRA_INFOFILES="" \
+ install
+
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_install
+ popd
+ fi
+
+ dodoc AUTHORS ChangeLog FAQ HACKING NEWS README* TODO
+}
diff --git a/app-pda/coldsync/files/coldsync-2.2.5-toolchain.patch b/app-pda/coldsync/files/coldsync-2.2.5-toolchain.patch
new file mode 100644
index 000000000000..1a5392d97f0b
--- /dev/null
+++ b/app-pda/coldsync/files/coldsync-2.2.5-toolchain.patch
@@ -0,0 +1,25 @@
+--- src/symboltable.cc
++++ src/symboltable.cc
+@@ -11,8 +11,11 @@
+ #include <string>
+ #include <map>
+ #include <cstdlib> // For malloc() and friends
++#include <cstring> // For strlen() and friends
+ #include "symboltable.h"
+
++using namespace std;
++
+ static char *make_c_string(const string &s);
+
+ map<string,string> table; /* XXX - Is this going to cause problems on
+--- src/symboltable.h
++++ src/symboltable.h
+@@ -26,7 +26,7 @@
+ /* Initialize the symbol table based on the
+ * arguments. */
+ #ifdef __cplusplus
+-};
++}
+ #endif /* __cplusplus */
+
+ /* This is for Emacs's benefit:
diff --git a/app-pda/coldsync/files/coldsync-3.0_pre4-texinfo-5.patch b/app-pda/coldsync/files/coldsync-3.0_pre4-texinfo-5.patch
new file mode 100644
index 000000000000..0579a9fb854e
--- /dev/null
+++ b/app-pda/coldsync/files/coldsync-3.0_pre4-texinfo-5.patch
@@ -0,0 +1,27 @@
+Fix building against texinfo >= 5.0
+
+http://bugs.gentoo.org/514772
+http://www.gnu.org/software/texinfo/manual/texinfo/texinfo.html#g_t_0040copyright
+
+--- doc/conduits.texi
++++ doc/conduits.texi
+@@ -33,7 +33,7 @@
+
+ @page
+ @vskip 0pt plus 1filll
+-Copyright @copyright 2000 Andrew Arensburger.
++Copyright @copyright{} 2000 Andrew Arensburger.
+
+ Permission is granted to make and distribute verbatim copies of
+ this manual provided the copyright notice and this permission notice
+--- doc/libpalm.texi
++++ doc/libpalm.texi
+@@ -57,7 +57,7 @@
+
+ @page
+ @vskip 0pt plus 1filll
+-Copyright @copyright 1999 Andrew Arensburger.
++Copyright @copyright{} 1999 Andrew Arensburger.
+
+ Permission is granted to make and distribute verbatim copies of
+ this manual provided the copyright notice and this permission notice
diff --git a/app-pda/coldsync/metadata.xml b/app-pda/coldsync/metadata.xml
new file mode 100644
index 000000000000..228404d3a4b2
--- /dev/null
+++ b/app-pda/coldsync/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>pda</herd>
+</pkgmetadata>