summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-01-24 21:20:15 -0500
committerMike Gilbert <floppym@gentoo.org>2016-01-24 21:21:07 -0500
commitc60e3d690e7a2254893cd21285d62135660c8405 (patch)
treeda448676df38d351ca6276e053865fdafea6f2dc /app-pda/libimobiledevice/libimobiledevice-1.2.0.ebuild
parentapp-pda/libplist: Override PYTHON_LDFLAGS in src_configure (diff)
downloadgentoo-c60e3d690e7a2254893cd21285d62135660c8405.tar.gz
gentoo-c60e3d690e7a2254893cd21285d62135660c8405.tar.bz2
gentoo-c60e3d690e7a2254893cd21285d62135660c8405.zip
app-pda/libimobiledevice: Override PYTHON_LDFLAGS in src_configure
Works around broken build system. Bug: https://bugs.gentoo.org/567916 Package-Manager: portage-2.2.27_p49
Diffstat (limited to 'app-pda/libimobiledevice/libimobiledevice-1.2.0.ebuild')
-rw-r--r--app-pda/libimobiledevice/libimobiledevice-1.2.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-pda/libimobiledevice/libimobiledevice-1.2.0.ebuild b/app-pda/libimobiledevice/libimobiledevice-1.2.0.ebuild
index 9a6116918c94..00223271c714 100644
--- a/app-pda/libimobiledevice/libimobiledevice-1.2.0.ebuild
+++ b/app-pda/libimobiledevice/libimobiledevice-1.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -51,8 +51,13 @@ src_configure() {
popd >/dev/null || die
}
+ do_configure_python() {
+ # Bug 567916
+ PYTHON_LDFLAGS="$(python_get_LIBS)" do_configure "$@"
+ }
+
do_configure --without-cython
- use python && python_foreach_impl do_configure
+ use python && python_foreach_impl do_configure_python
}
src_compile() {