summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/libsyncml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/libsyncml')
-rw-r--r--app-pda/libsyncml/Manifest1
-rw-r--r--app-pda/libsyncml/libsyncml-0.5.4.ebuild60
-rw-r--r--app-pda/libsyncml/libsyncml-9999.ebuild57
-rw-r--r--app-pda/libsyncml/metadata.xml9
4 files changed, 127 insertions, 0 deletions
diff --git a/app-pda/libsyncml/Manifest b/app-pda/libsyncml/Manifest
new file mode 100644
index 000000000000..cfe1de84db65
--- /dev/null
+++ b/app-pda/libsyncml/Manifest
@@ -0,0 +1 @@
+DIST libsyncml-0.5.4.tar.bz2 289488 SHA256 5ee4c48923ae78489fd13a4329d6a86bcb020bb777f9bc1b35d152f197b748ff SHA512 aed0821d01eaaa3fef69d559820875591d3837b3968be24293fc41924b3599a2810d2b4cc29f82e6f4058a212eae5f71021bd96a046b568e7cb1a036ba8f37aa WHIRLPOOL f036a5bf991ed76fe66c709bcb5ac3cc9f974d91b2b2fcdba3fc21fbab6c7a9b69ce5675c6a65ccc73261e0ec3c732a8c4124a8764e656a288385f9847112fe6
diff --git a/app-pda/libsyncml/libsyncml-0.5.4.ebuild b/app-pda/libsyncml/libsyncml-0.5.4.ebuild
new file mode 100644
index 000000000000..498786bf2fa3
--- /dev/null
+++ b/app-pda/libsyncml/libsyncml-0.5.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Implementation of the SyncML protocol"
+HOMEPAGE="http://libsyncml.opensync.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="debug doc http +obex test"
+
+# bluetooth and obex merged because bluetooth support in obex backend is
+# automagic, bug #285040
+# libsoup:2.2 is forced off to avoid automagic
+RDEPEND=">=dev-libs/glib-2.12
+ >=dev-libs/libwbxml-0.11.0
+ dev-libs/libxml2
+ http? ( net-libs/libsoup:2.4 )
+ obex? (
+ net-wireless/bluez
+ >=dev-libs/openobex-1.1[bluetooth] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( >=dev-libs/check-0.9.7 )"
+
+REQUIRED_USE="|| ( http obex )"
+
+DOCS="AUTHORS CODING ChangeLog RELEASE"
+
+src_prepare() {
+ # http://bugs.gentoo.org/425738
+ sed -i \
+ -e '/include/s:wbxml.h:wbxml/&:' \
+ libsyncml/parser/sml_wbxml_internals.h tests/mobiles/obex_mobile_ds_client.c || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DHAVE_LIBSOUP22=OFF
+ -DDOC_INSTALL_DIR=/usr/share/doc/${PF}
+ $(cmake-utils_use_enable debug TRACE)
+ $(cmake-utils_use_enable http HTTP)
+ $(cmake-utils_use_enable obex OBEX)
+ $(cmake-utils_use_enable obex BLUETOOTH)
+ $(cmake-utils_use_enable test UNIT_TEST)
+ )
+
+ if use http && use obex; then
+ # Doc builds with those previous USE flags only
+ mycmakeargs+=( $(cmake-utils_use_build doc DOCUMENTATION) )
+ fi
+
+ cmake-utils_src_configure
+}
diff --git a/app-pda/libsyncml/libsyncml-9999.ebuild b/app-pda/libsyncml/libsyncml-9999.ebuild
new file mode 100644
index 000000000000..55398a404637
--- /dev/null
+++ b/app-pda/libsyncml/libsyncml-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils subversion
+
+DESCRIPTION="Implementation of the SyncML protocol"
+HOMEPAGE="http://libsyncml.opensync.org/"
+SRC_URI=""
+
+ESVN_REPO_URI="http://svn.opensync.org/libsyncml/trunk"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="+debug doc http +obex test"
+
+# bluetooth and obex merged because bluetooth support in obex backend is
+# automagic, bug #285040
+# libsoup:2.2 is forced off to avoid automagic
+RDEPEND=">=dev-libs/glib-2.12
+ >=dev-libs/libwbxml-0.11.0
+ dev-libs/libxml2
+ http? ( net-libs/libsoup:2.4 )
+ obex? (
+ net-wireless/bluez
+ >=dev-libs/openobex-1.1[bluetooth] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( >=dev-libs/check-0.9.7 )"
+
+REQUIRED_USE="|| ( http obex )"
+
+DOCS="AUTHORS CODING ChangeLog RELEASE"
+
+src_prepare() {
+ # http://bugs.gentoo.org/425738
+ sed -i \
+ -e '/include/s:wbxml.h:wbxml/&:' \
+ libsyncml/parser/sml_wbxml_internals.h tests/mobiles/obex_mobile_ds_client.c || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DHAVE_LIBSOUP22=OFF
+ $(cmake-utils_use_build doc DOCUMENTATION)
+ $(cmake-utils_use_enable debug TRACE)
+ $(cmake-utils_use_enable http HTTP)
+ $(cmake-utils_use_enable obex OBEX)
+ $(cmake-utils_use_enable obex BLUETOOTH)
+ $(cmake-utils_use_enable test UNIT_TEST)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/app-pda/libsyncml/metadata.xml b/app-pda/libsyncml/metadata.xml
new file mode 100644
index 000000000000..7f678747a0bd
--- /dev/null
+++ b/app-pda/libsyncml/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>pda</herd>
+ <use>
+ <flag name='http'>Enable http transports</flag>
+ <flag name='obex'>Enable obex transports</flag>
+ </use>
+</pkgmetadata>