summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-03-22 22:28:32 +0000
committerJames Le Cuirot <chewi@gentoo.org>2020-03-23 22:58:09 +0000
commit8ad42e7b9a361d52a83f4161297c3cbc62dbea95 (patch)
tree6f1b911f8246b9f7ee1d2e8f0b0910ce7c0c7aac /app-pda/usbmuxd
parentapp-pda/libimobiledevice: Bump to pre-1.2.1 snapshot, EAPI 7 (diff)
downloadgentoo-8ad42e7b9a361d52a83f4161297c3cbc62dbea95.tar.gz
gentoo-8ad42e7b9a361d52a83f4161297c3cbc62dbea95.tar.bz2
gentoo-8ad42e7b9a361d52a83f4161297c3cbc62dbea95.zip
app-pda/usbmuxd: Bump to pre-1.1.1 snapshot, EAPI 7
Package-Manager: Portage-2.3.94, Repoman-2.3.20 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-pda/usbmuxd')
-rw-r--r--app-pda/usbmuxd/Manifest1
-rw-r--r--app-pda/usbmuxd/usbmuxd-1.1.1_pre20200121.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-pda/usbmuxd/Manifest b/app-pda/usbmuxd/Manifest
index 7e34f3e1521c..7c2c79565f0f 100644
--- a/app-pda/usbmuxd/Manifest
+++ b/app-pda/usbmuxd/Manifest
@@ -1 +1,2 @@
DIST usbmuxd-1.1.0.tar.bz2 321897 BLAKE2B 3ca5d1da222e457ac01f3e87fb7573c6405e51fd5d270a2b3dab7601118f21be22232d5100b4d027273fc837e6a57f7a7d17d2c41ae59d7c5aa41f76bef5a03d SHA512 66aa0c40e912bf596b819098b87d88e9cf30b2e6352e607eeb778bd4f23bf9bb123fb6a6ecca2d4e4be3171e35d66200d632d2c9c80b1f2462bb45be8aa6912d
+DIST usbmuxd-1.1.1_pre20200121.tar.bz2 51859 BLAKE2B 339d53904f7484bebb6d7524313ee065bf5a244efab16c77b30b8932071012105f21aa56083d82667b06088af83464ea8c86e3c28c5a45cb9abbe574a634533e SHA512 cc113b054e8e04d228af740ec43d2dbf29c015dc9d8e1cdd0eaf84bfcaa9838d5b1bf6db2efed30ffb84c35c88db5469983a115ffdbddbb6acd0df9fd2a5182f
diff --git a/app-pda/usbmuxd/usbmuxd-1.1.1_pre20200121.ebuild b/app-pda/usbmuxd/usbmuxd-1.1.1_pre20200121.ebuild
new file mode 100644
index 000000000000..371f8cb38f28
--- /dev/null
+++ b/app-pda/usbmuxd/usbmuxd-1.1.1_pre20200121.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT="8a69f1a78a58476f77b66916091d2405d0cd815f"
+
+inherit autotools systemd udev
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="https://www.libimobiledevice.org/"
+SRC_URI="https://cgit.libimobiledevice.org/usbmuxd.git/snapshot/usbmuxd-${COMMIT}.tar.bz2 -> ${P}.tar.bz2"
+
+# src/utils.h is LGPL-2.1+, rest is found in COPYING*
+LICENSE="GPL-2 GPL-3 LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="systemd"
+
+DEPEND="
+ acct-user/usbmux
+ >=app-pda/libimobiledevice-1.2.1_pre0:=
+ >=app-pda/libplist-1.11:=
+ virtual/libusb:1"
+
+RDEPEND="
+ ${DEPEND}
+ virtual/udev
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with systemd) \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-udevrulesdir="$(get_udevdir)"/rules.d
+}