summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-01-24 21:14:31 -0500
committerMike Gilbert <floppym@gentoo.org>2016-01-24 21:21:04 -0500
commit0f0051b915b593a44b9150be6d1744a7ea1215d0 (patch)
tree565b11ce919336238992267bff21f17569223899 /app-pda
parentapp-doc/pms: Reassign to PMS project. (diff)
downloadgentoo-0f0051b915b593a44b9150be6d1744a7ea1215d0.tar.gz
gentoo-0f0051b915b593a44b9150be6d1744a7ea1215d0.tar.bz2
gentoo-0f0051b915b593a44b9150be6d1744a7ea1215d0.zip
app-pda/libplist: Override PYTHON_LDFLAGS in src_configure
Works around broken build system. Bug: https://bugs.gentoo.org/567370 Package-Manager: portage-2.2.27_p49
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libplist/libplist-1.11-r2.ebuild13
-rw-r--r--app-pda/libplist/libplist-1.12.ebuild13
2 files changed, 12 insertions, 14 deletions
diff --git a/app-pda/libplist/libplist-1.11-r2.ebuild b/app-pda/libplist/libplist-1.11-r2.ebuild
index 600f79c1a041..e19af75e9a17 100644
--- a/app-pda/libplist/libplist-1.11-r2.ebuild
+++ b/app-pda/libplist/libplist-1.11-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -29,11 +29,6 @@ RESTRICT="test" # TODO: src_test() was dropped from 1.10 (cmake) -> 1.11 (autoto
BUILD_DIR="${S}_build"
-src_prepare() {
- sed -i -e 's/AC_PYTHON_DEVEL/AX_PYTHON_DEVEL/' "${S}"/m4/cython_python.m4
- eautoreconf
-}
-
src_configure() {
local ECONF_SOURCE=${S}
local myeconfargs=( $(use_enable static-libs static) )
@@ -45,8 +40,12 @@ src_configure() {
popd >/dev/null || die
}
+ do_configure_python() {
+ PYTHON_LDFLAGS="$(python_get_LIBS)" do_configure "$@"
+ }
+
do_configure --without-cython
- use python && python_foreach_impl do_configure
+ use python && python_foreach_impl do_configure_python
}
src_compile() {
diff --git a/app-pda/libplist/libplist-1.12.ebuild b/app-pda/libplist/libplist-1.12.ebuild
index bc3d53f8a9d8..8f40dc7a7419 100644
--- a/app-pda/libplist/libplist-1.12.ebuild
+++ b/app-pda/libplist/libplist-1.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -29,11 +29,6 @@ RESTRICT="test" # TODO: src_test() was dropped from 1.10 (cmake) -> 1.11 (autoto
BUILD_DIR="${S}_build"
-src_prepare() {
- sed -i -e 's/AC_PYTHON_DEVEL/AX_PYTHON_DEVEL/' "${S}"/m4/cython_python.m4
- eautoreconf
-}
-
src_configure() {
local ECONF_SOURCE=${S}
local myeconfargs=( $(use_enable static-libs static) )
@@ -45,8 +40,12 @@ src_configure() {
popd >/dev/null || die
}
+ do_configure_python() {
+ PYTHON_LDFLAGS="$(python_get_LIBS)" do_configure "$@"
+ }
+
do_configure --without-cython
- use python && python_foreach_impl do_configure
+ use python && python_foreach_impl do_configure_python
}
src_compile() {