summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-08 12:48:16 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-08 12:48:30 +0200
commit41052729dcea16bfe157728a6e97d069456a92ad (patch)
treea44ccb23aa80088323a37ce73c9033d31be8cd7b /app-portage/cpuid2cpuflags/cpuid2cpuflags-10.ebuild
parentapp-text/texlive-core: revbump to fix xindy support (diff)
downloadgentoo-41052729dcea16bfe157728a6e97d069456a92ad.tar.gz
gentoo-41052729dcea16bfe157728a6e97d069456a92ad.tar.bz2
gentoo-41052729dcea16bfe157728a6e97d069456a92ad.zip
app-portage/cpuid2cpuflags: Bump to v10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/cpuid2cpuflags/cpuid2cpuflags-10.ebuild')
-rw-r--r--app-portage/cpuid2cpuflags/cpuid2cpuflags-10.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-portage/cpuid2cpuflags/cpuid2cpuflags-10.ebuild b/app-portage/cpuid2cpuflags/cpuid2cpuflags-10.ebuild
new file mode 100644
index 000000000000..365682172c57
--- /dev/null
+++ b/app-portage/cpuid2cpuflags/cpuid2cpuflags-10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tool to guess CPU_FLAGS_* flags for the host"
+HOMEPAGE="https://github.com/mgorny/cpuid2cpuflags"
+SRC_URI="https://github.com/mgorny/cpuid2cpuflags/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+pkg_postinst() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if [[ ${v%-r*} -lt 2 ]]; then
+ elog 'Please note that the output has changed in v2. The new format is suitable'
+ elog 'both for Portage and Paludis. To use it, e.g.:'
+ elog
+ elog ' $ echo "*/* $(cpuid2cpuflags)" > /etc/portage/package.use/00cpuflags'
+ elog
+ elog '(you may need to convert package.use into a directory if you want to use'
+ elog ' separate file as presented here)'
+ fi
+ done
+}