summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-06 07:56:11 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-06 07:56:11 +0200
commitb6294d37081fb2a9fac2f5918dfad567893be9fa (patch)
tree2cc7758d848bd8dc12b3807c8b93d0f85b7a5a8d /app-portage/eix
parentnet-misc/econnman: add python-3.10 compatibility (diff)
downloadgentoo-b6294d37081fb2a9fac2f5918dfad567893be9fa.tar.gz
gentoo-b6294d37081fb2a9fac2f5918dfad567893be9fa.tar.bz2
gentoo-b6294d37081fb2a9fac2f5918dfad567893be9fa.zip
app-portage/eix: Bump to 0.35.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/eix')
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.35.0.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index acf9d04877f5..3fa275baa37c 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1 +1,2 @@
DIST eix-0.34.12.tar.xz 629704 BLAKE2B 22c3a93b47c607467321445704c8b4fe0f8b131081609709ebe5e2bd09d0ac08194938641ab44304e51d9dc4d473615625a9ca0de649767b6552c60d38974b75 SHA512 458a01b8ccb5fe4c7fbf9eb8368dbb0c63ac587e0452de4c3a58fadfc62aa8b404e509d6f24d20956bd6f04c00bfdfc95d6bf59287c5ea9e07091bea67f8c4e2
+DIST eix-0.35.0.tar.xz 636432 BLAKE2B 8a880cde56c0010f193445d9813c533effd59b8ee570132a0c40d62de827968839d99ee16981d152e737b881519e9f73d4ddac5375b6339dd480064deefa6149 SHA512 b9a6e59e666ec6015a612e083839a11a77e1d649262a802a9c8684fe25abbeda7a2c51ea629f1bb85ddc77fccce42b577178284763668bb2d1bcc85df5d68f2e
diff --git a/app-portage/eix/eix-0.35.0.ebuild b/app-portage/eix/eix-0.35.0.ebuild
new file mode 100644
index 000000000000..a13024c139e6
--- /dev/null
+++ b/app-portage/eix/eix-0.35.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1 flag-o-matic tmpfiles
+
+DESCRIPTION="Search and query ebuilds"
+HOMEPAGE="https://github.com/vaeth/eix/"
+SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug doc nls sqlite"
+
+DEPEND="
+ nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${DEPEND}
+ >=app-shells/push-2.0-r1
+ >=app-shells/quoter-3.0_p2-r1"
+BDEPEND="
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ # remove stale cache file to prevent collisions
+ local old_cache=${EROOT}/var/cache/${PN}
+ if [[ -f ${old_cache} ]]; then
+ rm "${old_cache}" || die
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
+
+ sed -e "/eixf_source=/s:push.sh:cat \"${EPREFIX}/usr/share/push/push.sh\":" \
+ -e "/eixf_source=/s:quoter_pipe.sh:cat \"${EPREFIX}/usr/share/quoter/quoter_pipe.sh\":" \
+ -i src/eix-functions.sh.in || die
+ sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EPREFIX}/usr/share/eix/eix-functions\\\\\":" \
+ -i src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug paranoic-asserts)
+ $(use_enable nls)
+ $(use_with doc extra-doc)
+ $(use_with sqlite)
+ --without-protobuf
+
+ # default configuration
+ $(use_with prefix always-accept-keywords)
+ --with-dep-default
+ --with-required-use-default
+
+ # paths
+ --with-portage-rootpath="${ROOTPATH}"
+ --with-eprefix-default="${EPREFIX}"
+
+ # build a single executable with symlinks
+ --disable-separate-binaries
+ --disable-separate-tools
+
+ # used purely to control/disrespect *FLAGS
+ --disable-debugging
+ --disable-new_dialect
+ --disable-optimization
+ --disable-strong-optimization
+ --disable-security
+ --disable-nopie-security
+ --disable-strong-security
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ dotmpfiles tmpfiles.d/eix.conf
+
+ rm -r "${ED}"/usr/bin/eix-functions.sh || die
+}
+
+pkg_postinst() {
+ tmpfiles_process eix.conf
+
+ local obs=${EROOT}/var/cache/eix.previous
+ if [[ -f ${obs} ]]; then
+ ewarn "Found obsolete ${obs}, please remove it"
+ fi
+}
+
+pkg_postrm() {
+ if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
+ rm -rf "${EROOT}/var/cache/${PN}" || die
+ fi
+}