summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Vesely <jano.vesely@gmail.com>2022-05-28 11:36:04 -0400
committerSam James <sam@gentoo.org>2022-06-06 06:14:52 +0100
commit003b014a7c4207ca31999ad4e617b331b0acac5e (patch)
tree2951f2689f694f05beaf97189006f9bffc0355fe /app-portage/elicense
parentapp-misc/lirc: add note re autoreconf (diff)
downloadgentoo-003b014a7c4207ca31999ad4e617b331b0acac5e.tar.gz
gentoo-003b014a7c4207ca31999ad4e617b331b0acac5e.tar.bz2
gentoo-003b014a7c4207ca31999ad4e617b331b0acac5e.zip
app-portage/elicense: Allow python:3.10 and pypy3
Both pypy3 and python:3.10 are already supported by a stable version of sys-apps/portage. Drop python:3.7. v2: Mask pypy3 useflag on selinux profile (portage with USE pypy3 is not available) Bug: https://bugs.gentoo.org/show_bug.cgi?id=842786 Signed-off-by: Jan Vesely <jano.vesely@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25665 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage/elicense')
-rw-r--r--app-portage/elicense/elicense-1.0.2.ebuild2
-rw-r--r--app-portage/elicense/elicense-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/app-portage/elicense/elicense-1.0.2.ebuild b/app-portage/elicense/elicense-1.0.2.ebuild
index d564118c306a..aff71477b274 100644
--- a/app-portage/elicense/elicense-1.0.2.ebuild
+++ b/app-portage/elicense/elicense-1.0.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
if [[ ${PV} == "9999" ]]; then
diff --git a/app-portage/elicense/elicense-9999.ebuild b/app-portage/elicense/elicense-9999.ebuild
index 831da3331919..6028d25eb4ee 100644
--- a/app-portage/elicense/elicense-9999.ebuild
+++ b/app-portage/elicense/elicense-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
if [[ ${PV} == "9999" ]]; then