summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-12-05 16:18:07 +0100
committerFabian Groffen <grobian@gentoo.org>2020-12-05 16:18:18 +0100
commitbb38524702384def9d248bfdc092b44537b1eef8 (patch)
tree69041eb0083066831dc352f8fca8eb710ef8e324 /app-portage/elt-patches/elt-patches-20201205.ebuild
parentsys-devel/libtool-2.4.6: add macOS Big Sur patch (diff)
downloadgentoo-bb38524702384def9d248bfdc092b44537b1eef8.tar.gz
gentoo-bb38524702384def9d248bfdc092b44537b1eef8.tar.bz2
gentoo-bb38524702384def9d248bfdc092b44537b1eef8.zip
app-portage/elt-patches-20201205: version bump for macOS Big Sur fix
Closes: https://bugs.gentoo.org/758473 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-portage/elt-patches/elt-patches-20201205.ebuild')
-rw-r--r--app-portage/elt-patches/elt-patches-20201205.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-portage/elt-patches/elt-patches-20201205.ebuild b/app-portage/elt-patches/elt-patches-20201205.ebuild
new file mode 100644
index 000000000000..e6ebc44e78a3
--- /dev/null
+++ b/app-portage/elt-patches/elt-patches-20201205.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Collection of patches for libtool.eclass"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elt-patches.git/"
+SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~x86-cygwin ~amd64-linux ~arm64-linux ~ppc64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND="sys-apps/gentoo-functions"
+DEPEND="app-arch/xz-utils"
+
+src_compile() {
+ emake rootprefix="${EPREFIX}" libdirname="$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" rootprefix="${EPREFIX}" install
+}