summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-08-27 17:16:15 +0200
committerFabian Groffen <grobian@gentoo.org>2021-08-27 17:21:18 +0200
commit614727a0b0a9dd84b417699f7131fc724ac58382 (patch)
tree0d6a2f31527bbc8ed3760499a43a533ef34c0c95 /app-portage/elt-patches
parentgnome-base/gnome-light: keyword ~riscv (diff)
downloadgentoo-614727a0b0a9dd84b417699f7131fc724ac58382.tar.gz
gentoo-614727a0b0a9dd84b417699f7131fc724ac58382.tar.bz2
gentoo-614727a0b0a9dd84b417699f7131fc724ac58382.zip
app-portage/elt-patches-20210827: version bump for conf-darwin20 update
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-portage/elt-patches')
-rw-r--r--app-portage/elt-patches/Manifest1
-rw-r--r--app-portage/elt-patches/elt-patches-20210827.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-portage/elt-patches/Manifest b/app-portage/elt-patches/Manifest
index 6344aa49022c..1070f6bb4e06 100644
--- a/app-portage/elt-patches/Manifest
+++ b/app-portage/elt-patches/Manifest
@@ -1 +1,2 @@
DIST elt-patches-20201205.tar.xz 39240 BLAKE2B aa2e2377f0d0cba14f38c59664174d066eff04c9d2a71346c998c4324987fbce25cfd91b79e8e40bde0d81bf7d3c43126bffd0a6b0b219aaad11f4f9f22abde4 SHA512 67e199f060e2c93e01b7a7809f52c0a18d82e86f1b1eb34b965c2acd24e5538a874b820028e363d3002cf58b43c2fe3376ae28d2bef0ca81feabb90c83ae47c2
+DIST elt-patches-20210827.tar.xz 39264 BLAKE2B 271565e4ab906374ca30f69f5ebc8c14cbda5c176b7d54de4315adf83c12111cab4d04254f5bbbc13cf6bc701ba8a940def98e3a983d199ca6aedfe82a280682 SHA512 bf7d50df82e6335879ba4e130817bce67c4e63c55e2ac7249fa35b60f6b73290f857562433477907283b41b137bf12ee254b5bea20f8eebf173c6584d74f5e49
diff --git a/app-portage/elt-patches/elt-patches-20210827.ebuild b/app-portage/elt-patches/elt-patches-20210827.ebuild
new file mode 100644
index 000000000000..bc94d8304da6
--- /dev/null
+++ b/app-portage/elt-patches/elt-patches-20210827.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Collection of patches for libtool.eclass"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elt-patches.git/"
+SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~arm64-linux ~ppc64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+
+RDEPEND="sys-apps/gentoo-functions"
+BDEPEND="app-arch/xz-utils"
+
+src_compile() {
+ emake rootprefix="${EPREFIX}" libdirname="$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" rootprefix="${EPREFIX}" install
+}